Flickering of image on page

RESOLVED WORKSFORME
(NeedInfo from)

Status

()

RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: sawrubh, Unassigned, NeedInfo)

Tracking

({regression, reproducible, testcase})

unspecified
x86_64
Linux
regression, reproducible, testcase
Points:
---

Firefox Tracking Flags

(firefox31 ?, firefox32 ?, firefox33 affected, firefox34 affected)

Details

(URL)

(Reporter)

Description

4 years ago
STR:

* Visit http://www.hackerearth.com/users/rajat.khandelwal.iitd/?source=home-page
* Scroll down to 'Competitive Coding' section.

What happens:
The `H` besides the 'HackerEarth' keeps flickering. This flickering doesn't happen in Chrome.

Comment 1

4 years ago
I can reproduce this on Linux, but not OS X. I suspect it's a graphics issue...
Keywords: reproducible, testcase

Comment 2

4 years ago
I'm looking for a regression window - it broke somewhere in Q2 this year.
Keywords: regression, regressionwindow-wanted

Comment 4

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=67f48cc4e6c9&tochange=0f2821706cdb

I can't mark this blocking bug 913805 because it's sec-sensitive, although I wonder if the locking issue there was essentially just a pre-existing issue that was masked or something... in any case, Seth, George, can you look at this in more detail?
Flags: needinfo?(seth)
Flags: needinfo?(gwright)
Keywords: regressionwindow-wanted

Updated

4 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Comment 5

4 years ago
This was uplifted to 32 and landed on 33 - I don't know if this affects 32 or 31 if this was just masked by the pre-existing bug, or something...
status-firefox31: --- → ?
status-firefox32: --- → ?
status-firefox33: --- → affected
status-firefox34: --- → affected
(Reporter)

Comment 6

4 years ago
I get it on Windows too btw. Latest nightly, going on http://www.smartprix.com/about/us, the image of 'Abhinav Choudhary' keeps flickering ominously.

Comment 7

4 years ago
(In reply to Saurabh Anand [:sawrubh] from comment #6)
> I get it on Windows too btw. Latest nightly, going on
> http://www.smartprix.com/about/us, the image of 'Abhinav Choudhary' keeps
> flickering ominously.

This comment may be different problem, because these image are also wavering and flickering in Google chome.
I can't reproduce the original bug (the H symbol flickering), and the flickering reported in comment 6 is intentional; this is in the source for that page:

function posTwitch($ele, posx, posy)
{
	new_posx = posx + Math.floor(Math.random()*3-1);
	new_posy = posy + Math.floor(Math.random()*3-1);
	
	$ele.css({'background-position': new_posx + 'px ' + new_posy + 'px'});
}

function opacityTwitch($ele)
{
	opacity = 1 - Math.random()*0.1;
	if(opacity > .95) opacity = 1;
	$ele.css({'opacity': opacity});
}

Let's close this.
Flags: needinfo?(gwright)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.