Closed Bug 1047986 Opened 5 years ago Closed 5 years ago

Thunderbird's compose window overrides the GTK theme for the worse

Categories

(Thunderbird :: Message Compose Window, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1042780

People

(Reporter: calimeroteknik, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140722064054

Steps to reproduce:

The UI to ignores more and more of my GTK theme's entities, but so far only replaced them with okay stuff.

Running thunderbird 31 today, I found that this had gone too far. Even the input fields are now using some sort of flat-design, low-contrast theming, completely ignoring my system (gtk2) theme.

This the most closely related bug report I could find (which is general gripe): https://bugzilla.mozilla.org/show_bug.cgi?id=617899


Actual results:

The compose window has become unusable due to uniform color and low contrast.

There also is some grain in the background of that new UI stuff. This had already been introduced and reverted here due to inherent theming problems:
https://bugzilla.mozilla.org/show_bug.cgi?id=845819 (introduction in th. 24 and problems)
https://bugzilla.mozilla.org/show_bug.cgi?id=935023 (reverted)


Expected results:

I would have expected my normal GTK2 theme to be used, like everywhere else in thunderbird.
Only the compose window's text fields seem to be broken.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1042780
You need to log in before you can comment on or make changes to this bug.