Collapsing margins only work after reflow

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Sampo Syreeni, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
On the example page, title box margins are collapsed erratically. In earlier
versions of Mozilla (currently using 0.9.4 MathML+SVG), box margins for h1 and
h2 elements sometimes collapse, sometimes not. The result does not appear
deterministic, and is occasionally correct upon reload.

In 0.9.4 the result seems to be consistenly wrong: the margins collapse to 0
after the initial load is complete. However, upon window resize/reflow Mozilla
consistently gets it right.

Note that network latency/cache hits may still provoke nondeterministic
behavior. If necessary, I can zip and attach the relevant files for a local
Apache install.

Comment 1

17 years ago
WFM 2001101408 NT4

Comment 2

17 years ago
WFM in the Oct 30th build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.