csid setting in ldap has no effect

NEW
Unassigned

Status

MailNews Core
LDAP Integration
--
major
17 years ago
7 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla doesn't seem to work 100% my my LDAP server (MS Exchange version
5.5.2232.11)

When I try to autocomplete a person named:
Peter Tæster <test@test.org>

Mozilla only shows:
Peter T <test@test.org>

The same thing used to be true with NS4 but in NS4 I could do:
user_pref("ldap_2.servers.TDCInternet.csid", "iso-8859-1");

and everything worked just fine! This does not work in Mozilla.

Since loggin of LDAP search is not enabled in the nightly builds I cant provide
any log files...
(Reporter)

Comment 1

17 years ago
Here's one of my problems with my LDAP server and international charsets.

In mozilla mail I'm looking for Morten Jørgensen. So I start typing mojo and
mozilla shows me:
Morten Jgensen <MOJO@ftt.dk>
Please note there's missing a "ør" in Jgensen

So I used a LDAP command line tool to get the info directory from the LDAP
directory and here's what I got:

dn: cn=MOJO,cn=Bruger,ou=td-inet-kbh,o=td-inet
objectClass: organizationalPerson
objectClass: person
objectClass: Top
rdn: MOJO
cn:: TW9ydGVuIErDuHJnZW5zZW4=
distinguishedName: cn=MOJO,cn=Bruger,ou=td-inet-kbh,o=td-inet
rfc822Mailbox: MOJO@ftt.dk
mail: MOJO@ftt.dk
textEncodedORaddress: c=DK;a= ;p=td-inet;o=td-inet-kbh;s=Jorgensen;g=Morten;
otherMailbox: MS$TDINET/TDINETKBH/MOJO
otherMailbox:: Q0NNQUlMJErDuHJnZW5zZW4sIE1vcnRlbiBhdCB0ZC1pbmV0LWtiaA==
givenName: Morten
uid: MOJO
MAPI-Recipient: TRUE
sn:: SsO4cmdlbnNlbg==

Basiclly my question is: why doesn't mozilla show the "ør" ?

build 20020108

Comment 2

17 years ago
See also bug 111200.

Comment 3

16 years ago
*** Bug 111200 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
I see this in the Address book LDAP all the time. We use MS Active Directory on
Windows 2000 as a LDAP server. I can't search names using accented characters
and when I use email address for searching (we have simple rule for name->email)
there is no name shown in the search results if it contains accented characters.
Severity: normal → major
Keywords: mozilla1.1
OS: Windows 2000 → All
Hardware: PC → All
Summary: csid in ldap setting has not effect → No support for non-ansi characters in LDAP

Comment 5

16 years ago
Sorry for spam: I forgot to mention I'm using latest nightly 2002060921 from
trunk on Linux.

Comment 6

16 years ago
Tom: This bug is LDAPv2 specific, and is almost certainly not the problem you
are having, given that active directory is LDAPv3 based.
Summary: No support for non-ansi characters in LDAP → csid setting in ldap has no effect

Updated

16 years ago
QA Contact: yulian → gchan
Product: MailNews → Core

Updated

10 years ago
Assignee: srilatha → nobody
QA Contact: grylchan → ldap-integration
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.