Closed Bug 1048065 Opened 6 years ago Closed 6 years ago

Tapping some search results open in the Search Activity

Categories

(Firefox for Android Graveyard :: Search Activity, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mfinkle, Unassigned)

References

Details

STR:
1. Open Search activity
2. Search for 'movies'
3. The search results should show "showtimes" for local theaters
4. Tap on the first one

Actual results:
* Another Yahoo search page opens in the same WebView

Expected results
* Link opens in Firefox

Honestly, I don't know if Yahoo is doing something on it's own or what. The next page is still a Yahoo search result, just for the specific theater I tapped. Maybe this is the 'best experience' anyway, but I'd like to know why it happens like it does. Even the progress bar kicks in.
By design we keep users in the search activity if they're navigating to another results page:
http://mxr.mozilla.org/mozilla-central/source/mobile/android/search/java/org/mozilla/search/PostSearchFragment.java#63
Blocks: search
If this is expected, then I'm OK with it. No need for any action until we get user feedback.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.