[Keyboard] Keyboard layout for "ja" locale is not defined in build config

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: marsf, Assigned: marsf)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.1 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Japanese locale code is misconfigured in "/build/config/keyboard-layouts.json".
Correct code for Japanese is "ja".
The json file was introduced in bug 920431. Therefore, this may affects to 1.4 and later.



Actual results:

  "jp": [
      {"layoutId": "jp-kanji", "app": ["apps", "keyboard"]},
      {"layoutId": "en", "app": ["apps", "keyboard"]}
  ],


Expected results:

  "ja": [
      {"layoutId": "jp-kanji", "app": ["apps", "keyboard"]},
      {"layoutId": "en", "app": ["apps", "keyboard"]}
  ],
(Assignee)

Updated

4 years ago
Flags: needinfo?(rlu)
Whiteboard: [3rd-party-keyboard]
Hi,
The naming is to reference the following file,
https://github.com/mozilla-b2g/gaia/blob/master/apps/keyboard/js/layouts/jp-kanji.js

[3rd-party-keyboard] flag was used to track the work around 3rd-party keyboard, so should be not applied to this bug.
Flags: needinfo?(rlu)
Whiteboard: [3rd-party-keyboard]
(Assignee)

Comment 2

4 years ago
Hi,

I'm understanding the layoutID is reference to "jp-kanji.js".
I mentioned in this bug is the system locale code, the part of "jp :[".
(Assignee)

Updated

4 years ago
Summary: [Keyboard] Keyboard layout for "ja" locale is misconfigured in build config → [Keyboard] Keyboard layout for "ja" locale is not defined in build config
(Assignee)

Comment 3

4 years ago
Created attachment 8466862 [details] [review]
Bug1048087.txt

https://github.com/mozilla-b2g/gaia/pull/22462

If I don't have mistakes, could you please take care of this?
Thanks.
Attachment #8466862 - Flags: review?(dflanagan)
(Assignee)

Comment 4

4 years ago
This bug enables Japanese IME by default on ja locale without specifying GAIA_KEYBOARD_LAYOUTS.
This is not critical, but just a typo.
Comment on attachment 8466862 [details] [review]
Bug1048087.txt

This looks okay to me, but I'd rather that Rudy reviewed it. I'm no longer familiar with how the keyboard_layouts.json file is used. I think that this change may affect some or all of: 

  the build system
  the setting app
  the FTU app

But things have changed a lot since I last worked on that part of the code so I'm not sure anymore.
Attachment #8466862 - Flags: review?(dflanagan) → review?(rlu)
(Assignee)

Comment 6

4 years ago
(In reply to David Flanagan [:djf] from comment #5)
> I think that this change may affect some or all of: 
> 
>   the build system
>   the setting app
>   the FTU app
> 

I couldn't find the typo used as system locale code in any other apps or config files.
Comment on attachment 8466862 [details] [review]
Bug1048087.txt

Yes, you're right.
Thanks for the correction.
Attachment #8466862 - Flags: review?(rlu) → review+
Landed to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/a0b79fef1f158fadc7d794202a680a75eea82f04
Assignee: nobody → chimantaea_mirabilis
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.