Netscape (v. 4.77) Address Book Import/Export when using tab delimited format has serious limitations

VERIFIED INVALID

Status

--
major
VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: ceeez, Assigned: rdayal)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Address Book Export Bugs
========================
From Netscape Address Book, go to pull-down menus and choose File -> Export...
Then select from the "Save As Type" list, the format "Tab Delimited 
(*.txt,*.tab)"
The file that is created contains the format in the line below:
DisplayName	LastName	FirstName	Notes	City	State	Email	
Title	Unknown1	Address	Zip	Country	Work	Fax	Home	
Organization	Nickname	Cellular	Pager	Unknown2
### in case the tabs are removed by form submition the format is
DisplayName(tab)LastName(tab)FirstName(tab)Notes(tab)City(tab)State(tab)Email(ta
b)Title(tab)Unknown1(tab)Address(tab)Zip(tab)Country(tab)Work(tab)Fax(tab)Home(t
ab)Organization(tab)Nickname(tab)Cellular(tab)Pager(tab)Unknown2
Note that the export is missing the 3 fields in a person record which hold 
values for "Prefers to receive Rich Text (HTML) mail" and "Department" and "URL"
Also note that there are two columns that ALWAYS have blank values (so I can't 
be sure what is being attempted to export). I have labelled them Unknown1 and 
Unknown2. Presumably, they are to contain 2 of the 3 missing values mentioned 
above

Address Book Import Bugs
========================
From Netscape Address Book, go to pull-down menus and choose File -> Import...
Choose from the list of import formats, the format named "Text file (address 
book)"
Choose a file that is tab-delimited with column order identical to the one 
created by address book export whose first line contains trailing blank values
It appears that Netscape parses only the first line to see how many fields 
should be permitted in the import and only allows you to map up to the last 
non-blank field found on the first line
Subsequent lines which may contain more values will not display those additional 
values to allow you to map them for the purposes of import.

For example, suppose your import file contained the following two lines:

Joe Shmoe	Shmoe	Joe		Toronto	ON	joe_shmoe@hahaha.com	
Joe Bloggs	Bloggs	Joe		Toronto	ON	joe_bloggs@hahah.com	
President

### in case the tabs are removed by form submition the format is
Joe 
Shmoe(tab)Shmoe(tab)Joe(tab)(tab)Toronto(tab)ON(tab)joe_shmoe@hahaha.com(tab)
Joe 
Bloggs(tab)Bloggs(tab)Joe(tab)(tab)Toronto(tab)ON(tab)joe_bloggs@hahah.com(tab)P
resident

Following the procedure described above, you would never be able to map the 8th 
column since it is blank in the first line (therefore we would never be able to 
import the fact the Joe Bloggs' title is President)
This necessitates a header line that may not contain any relevant values but is 
in place only to force Netscape to parse ALL fields. However, this line is not 
created by the export process forcing you to guess as to what each field might 
contain.

Further, even if the complete list of columns is displayed, the import process 
has no options to allow you to map the following fields originally exported by 
the address book export:
Display Name
URL

although curiously, it has the options
Department
Prefers HTML mail

Presumably those two map to the Unknown1 and Unknown2 fields that were (sort of) 
exported

Summary
=======
It is impossible to export data and the re-import the same data back (never mind 
making changes in an external program before importing it back)
(Reporter)

Updated

17 years ago
Component: LDAP Mail/News Integration → Address Book

Comment 1

17 years ago
Wait, wait... do I understand correctly; you are talking about the address book
in Netscape 4.x, right? I dont even see a File -> Export menu at all in
Mozilla's Address book.

This is not the place to report Netscape 4.x problems. Bugzilla is for reporting
Mozilla bugs.

Comment 2

17 years ago
Reassigning to rdayal since he worked on addressbook import.
Assignee: srilatha → rdayal
invalid !

This is not a Netscape Database and mozilla's Adressbook have no File/Export.
Please use Netscape's bug reporting form.



Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
Verified as invalid
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.