Table cell auto width incorrect when using overflow:hidden float containment

RESOLVED DUPLICATE of bug 1322843

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 1322843
3 years ago
8 months ago

People

(Reporter: Evan Greensmith, Unassigned)

Tracking

({testcase})

31 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [float pref width] DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8466889 [details]
Test Case.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Inside a table cell, place a float:left div followed by an overflow:hidden div. The effect is to place the overflow:hidden div to the right of the float:left div in a new block formatting context. See example.


Actual results:

The overflow:hidden div was placed to the right of the float:left div in a new block formatting context. The width of the cell was set as if the overflow:hidden div flowed below the float:left div.


Expected results:

The expected result was that the width of the div would be set to the combined width of the float:left div and the overflow:hidden div. This is how it renders in chrome (Version 36.0.1985.125 m) and Internet Explorer (Version 11.0.9600.17207).

It may also be reasonable to float the overflow:hidden div below the float:left div.

Updated

3 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Layout: Tables
Ever confirmed: true
Keywords: testcase
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86_64 → All
Component: Layout: Tables → Layout: Floats
Whiteboard: DUPEME
Whiteboard: DUPEME → [float pref width] DUPEME

Comment 1

8 months ago
This seems to have been fixed in Firefox 53; perhaps because of bug 1260031?

Comment 2

8 months ago
(In reply to Francesco from comment #1)
> This seems to have been fixed in Firefox 53; perhaps because of bug 1260031?

Xidorn, would that make sense and/or should we mark this as FIXED / a dupe, then? :-)
Flags: needinfo?(xidorn+moz)
This pretty much looks like an issue which is fixed by bug 1322843. I can mostly understand what happens in this case, I think.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(xidorn+moz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1322843

Comment 4

8 months ago
Curious, this bug originally reported for Firefox 31 turns out to be a duplicate of a regression that started in FF 49 (bug 1322843 comment 4). What I think happened is, good code caused a regression by relying on bad code and the fix found the bad code and addressed it. Nice job :-)
Bug 1322843 is for regression from bug 1260031, which is probably the same issue as this bug. The initial fix in the latter ends up being backed out in bug 1325496 because of that regression (the former bug). And a better fix of bug 1260031 was eventually landed in the bug 1322843.
You need to log in before you can comment on or make changes to this bug.