Feeds with <media:group> but without multiple <media:content> don't display

RESOLVED DUPLICATE of bug 1046500

Status

()

Firefox
RSS Discovery and Preview
RESOLVED DUPLICATE of bug 1046500
4 years ago
4 years ago

People

(Reporter: merike, Unassigned)

Tracking

({regression})

32 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
According to http://validator.w3.org/feed/docs/error/MediaGroupWithoutAlternatives.html http://www.postimees.ee/rss/ uses  <media:group> incorrectly. However, this feed displays a preview and works as a live bookmark in 31. 32.0b1 only displays one item from the feed and live bookmark does not work at all.

There is also the following error in browser console:
NS_NOINTERFACE: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWritablePropertyBag2.getPropertyAsInterface] FeedProcessor.js:547
Let's assume is a regression from bug 998063, since it's an rss preview change about mediagroup and landed in 32.

That said, since the feed is incorrect, we might end up converting this to a Tech Evangelism bug. Should evaluate whether the old code path made more sense.
Blocks: 998063
(Reporter)

Comment 2

4 years ago
When will you know which it will be: a bug to be fixed or an evangelism bug?

Current situation shouldn't make it to next release because until version 9.0.1 this live bookmark was shipped in Estonian, so that people with profiles old enough probably still have it. I think Estobuntu (Estonian customization of Ubuntu) also ships it as part of Firefox even now. If it turns out evangelism bug I could look for contacts to make them fix it instead.
Flags: needinfo?(mak77)
I think this is a duplicate of bug 1046500, that has a patch already landed in fx-team branch.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(mak77)
Resolution: --- → DUPLICATE
Duplicate of bug: 1046500
You need to log in before you can comment on or make changes to this bug.