Marionette gets error while an element of embedded iframe is triggering 'click' event to do 'window.close'.

RESOLVED DUPLICATE of bug 1223277

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 1223277
4 years ago
9 months ago

People

(Reporter: iliu@mozilla.com, ianliu.moz@gmail.com, Unassigned)

Tracking

({ateam-marionette-server})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Error log:
GenericError: (500) The frame closed during the click, recovering to allow further communications
I will create a branch with some sample code while I'm meeting the issue.
Created attachment 8466971 [details]
sample for reproduce marionette error

please run command:

make test-integration-test TEST_FILES=apps/settings/test/marionette/tests/bluetooth_settings_test.js

result:
  1) manipulate bluetooth settings Launch bluetooth's settings page:
     
  GenericError: (500) The frame closed during the click, recovering to allow further communications
  Remote Stack:
  <none>
      at Error.MarionetteError (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/error.js:67:13)
      at Object.Client._handleCallback (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/client.js:476:19)
      at /Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/client.js:510:21
      at TcpSync.send (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/drivers/tcp-sync.js:100:10)
      at Object.send (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/client.js:457:36)
      at Object.Client._sendCommand (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/client.js:503:19)
      at Object.Element._sendCommand (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/element.js:49:21)
      at Object.click (/Users/ian/Documents/Dev/gaia/node_modules/marionette-client/lib/marionette/element.js:176:19)
      at Object.BluetoothApp.goBackToSettingsApp (/Users/ian/Documents/Dev/gaia/apps/settings/test/marionette/app/bluetooth_app.js:40:16)
      at Context.<anonymous> (/Users/ian/Documents/Dev/gaia/apps/settings/test/marionette/tests/bluetooth_settings_test.js:31:18)
This is a marionette server-side bug and is likely related to bug 947317
Component: JSMarionette → Marionette
Keywords: ateam-marionette-server
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1223277
You need to log in before you can comment on or make changes to this bug.