[Text Selection] Text Selection caret should not be overlapped

RESOLVED DUPLICATE of bug 1096169

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED DUPLICATE of bug 1096169
3 years ago
3 years ago

People

(Reporter: Carol, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8466963 [details]
1970-01-06-09-15-11.png

Text Selection caret need to tilt outward when the caret are overlapped
I think you should update ux spec to determine which condition triggers tilt mode. You also need consider other overlapped case, such as in the multi-line textarea, first caret at first line and second caret at second line and they are overlapped. In this case even though you change the icon to tilt mode the carets still overlapped.
Created attachment 8466974 [details]
overlapped.png

example screenshot when two caret in different but they overlapped.
Hi Morris, I've updated the UX spec. Please see bug 921965 for details, thanks!
Flags: needinfo?(mtseng)

Comment 4

3 years ago
(In reply to Omega Feng [:Omega] [:馮於懋] from comment #3)
> Hi Morris, I've updated the UX spec. Please see bug 921965 for details,
> thanks!

This spec change is too late for us, and the experience of tilt use cases are a little strange for me. It's better to discuss with related ppl before spec changes in current stage.
Flags: needinfo?(mtseng)

Updated

3 years ago
QA Whiteboard: [textselection]
I think this is resolved by bug 1096169.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096169

Updated

3 years ago
QA Whiteboard: [textselection] → [COM=Text Selection]
You need to log in before you can comment on or make changes to this bug.