If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Keyboard should remember last used language

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Input Mgmt
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: janjongboom, Assigned: janjongboom)

Tracking

unspecified
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
janjongboom
: review+
Details | Review | Splinter Review
1. Have two languages configured on the keyboard (e.g. English, Dutch).
2. Switch to Dutch
3. Restart device and open keyboard
4. Expected: language is Dutch, actual: language is English
This is controlled by input management component.
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
(Assignee)

Updated

3 years ago
Assignee: nobody → janjongboom
Created attachment 8472377 [details] [review]
Patch

Here's a patch. It's not that crazy, just a new field in settings.
Attachment #8472377 - Flags: review?(rlu)
Comment on attachment 8472377 [details] [review]
Patch

I would give f- for this, because it seems this did not consider the "showAll" case when you switch the layout with the IME menu (longpress the IME switching key).

Besides, we should view a layout as a pair like {manifestURL, id}, please take a look at the comments on GH pull request.

--
BTW, you may want to ask for Tim's help to review this because this is in Gaia system component.
Attachment #8472377 - Flags: review?(rlu) → feedback-
Thanks, good point.
Comment on attachment 8472377 [details] [review]
Patch

Updated PR according to Rudy's feedback.
Attachment #8472377 - Flags: review?(timdream)
Attachment #8472377 - Flags: feedback?(rlu)
Attachment #8472377 - Flags: feedback-
Comment on attachment 8472377 [details] [review]
Patch

Sorry to f- again, but seems I cannot test your code.

When I run your code for the first time, I encountered:
08-14 18:28:00.651: E/GeckoConsole(15282): [JavaScript Error: "TypeError: curr is undefined" {file: "app://system.gaiamobile.org/shared/js/keyboard_helper.js" line: 880}]
08-14 18:28:05.861: E/GeckoConsole(15282): [JavaScript Error: "TypeError: curr is undefined" {file: "app://system.gaiamobile.org/shared/js/keyboard_helper.js" line: 880}]

Also commented here, https://github.com/mozilla-b2g/gaia/pull/22838#discussion_r16278554.
Attachment #8472377 - Flags: feedback?(rlu) → feedback-
(Assignee)

Updated

3 years ago
Attachment #8472377 - Flags: feedback- → feedback?(rlu)
Third time's the charm ))
Comment on attachment 8472377 [details] [review]
Patch

feedback? to :mnjul since he is working on bug 1053041.

This can land when all f? are f+'d.
Attachment #8472377 - Flags: review?(timdream)
Attachment #8472377 - Flags: review+
Attachment #8472377 - Flags: feedback?(jlu)
Comment on attachment 8472377 [details] [review]
Patch

Looks quite good to me, although we might have to override the logics when we do 942309 (if we finally have time to do that).
Attachment #8472377 - Flags: feedback?(jlu) → feedback+
Comment on attachment 8472377 [details] [review]
Patch

f+ from me.
Jan, thanks for your work!
Attachment #8472377 - Flags: feedback?(rlu) → feedback+
Landed https://github.com/mozilla-b2g/gaia/commit/deb73e71e32ccc26261de33d9f857ce5d429e2f6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Reverted for failures in keyboard_helper_test.js:
https://tbpl.mozilla.org/php/getParsedLog.php?id=46160802&tree=B2g-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=46161639&tree=B2g-Inbound

https://github.com/mozilla-b2g/gaia/commit/ba1992f2addc5a84afc2eab426f222a6bf2962ba
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Flags: needinfo?(janjongboom)
Can I ignore these intermittents? https://tbpl.mozilla.org/?rev=412c65594aa271e42f92ce66e9b79b5e49f111a6&tree=Gaia-Try
Flags: needinfo?(ryanvm)
They look real to me. Being perma-fail on all platforms and being keyboard related is what I'm going off.
Flags: needinfo?(ryanvm)
Yeah, caused by another patch and backed out already. Retriggered try.
Flags: needinfo?(janjongboom)
Created attachment 8482809 [details] [review]
Patch v2
Attachment #8472377 - Attachment is obsolete: true
Attachment #8482809 - Flags: review+
Alright, so I have a try run here https://tbpl.mozilla.org/?rev=a5a92c66f95f3ccd201af84c8855ba2cf10f701f&tree=Gaia-Try and Gb failed twice and succeeded once. Don't really know if this is good now or not (I broke the build a few days ago, hence my triple-checking :p).

I saw the same failure at another branch as well (1/3 times) https://tbpl.mozilla.org/?rev=0edf84c26ee82d67995b4f321ba83406376a3616&tree=Gaia-Try
Flags: needinfo?(ryanvm)
Gb is hidden by default on TBPL due to its flakiness. The failures match known intermittents (i.e. you're not introducing new bustage), so I think you're fine to ignore them.
Flags: needinfo?(ryanvm)
Green try https://tbpl.mozilla.org/?rev=17fc5f4c366c635ae5437681a4dbcef0ae5e3eb4&tree=Gaia-Try

Landed https://github.com/mozilla-b2g/gaia/commit/75da1e8de1e22dff6eea8976d83865a00f4b2cfd
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 893691
Depends on: 1080357
status-b2g-v2.2: --- → fixed
Duplicate of this bug: 999994
feature-b2g: --- → 2.2+
Depends on: 1094122
Depends on: 1097450

Comment 22

3 years ago
Remove the feature b2g tag to match the new v2.2 scope.
feature-b2g: 2.2+ → ---
You need to log in before you can comment on or make changes to this bug.