Java console remains loaded after all windows closed because of quick launch

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
enhancement
RESOLVED INVALID
17 years ago
4 years ago

People

(Reporter: Emilio Tejedor, Assigned: Joshua Xia)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; es-ES; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

When Quick Launch is activated, if java gets loaded, it will remain loaded after
closing all windows.
I think it should be unloaded from memory after all mozilla windows are closed.

Reproducible: Always
Steps to Reproduce:
1.Open a url that requires Java (Java conlose appears in the tray)
2.Close all mozilla windows
3.

Actual Results:  The Java console is still in the tray and Mozila.exe uses a lot
of memory.

Expected Results:  Unload the Java stuff from memory

Comment 1

17 years ago
yup, same thing happens for me...
until you exit mozilla, _completely_... including quick launch
No dupes found. Marking NEW.

-> enhancement

-> OJI

Adding block: bug 75599.
Assignee: asa → joe.chou
Blocks: 75599
Severity: minor → enhancement
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true
QA Contact: doronr → pmac

Comment 3

17 years ago
I can not reproduce this on win2k and linux with jre1.3.1.

If i close all windows except java console then console window 
is closed too.  

However java console item may stay in tray until tray will be 
refreshed (i.e. if i move mouse over java console icon 
then it will gone). Hovewer, i see 
no java or mozilla running at this time.

Which version of java plugin did you use?

Comment 4

17 years ago
Oops, forgot to enable quick launch last time.
Now i can reproduce it.

However, I am not sure whever this can be done. 
As far as i understand in quick launch mode mozilla does not 
really free any memory. In particular it stores parsed 
representation for already fetched pages. As a consequence 
some objects there may refere to java objects (e.g. liveconnect stuff, etc.)

We can not simply unload java without letting these object know 
about this. Also if after subsequent start user will visit 
such (visited before) page again then mozilla will not rebuild 
object tree and will show it as is causing java-related stuff to not work as
expected. 

i guess it will be much more realistic to implement if mozilla will 
deallocate page cache when last window is closed.  

See also bug 78159

Updated

16 years ago
No longer blocks: 75599

Updated

16 years ago
Blocks: 75599

Comment 5

16 years ago
same behaviour on Windows NT with Mozilla 1.0rc1

Updated

16 years ago
QA Contact: pmac → petersen

Comment 6

16 years ago
this has been open for over a year.... is anyone working on it?

if not, perhaps it's a good place for me to try to get involved in oss.... :)

(Assignee)

Comment 7

16 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Updated

15 years ago
Summary: Java console remains loaded after all windows closed → Java console remains loaded after all windows closed because of quick launch
(Assignee)

Comment 8

15 years ago
Hi, Reporter:

Did close all instance of Netscape?

Comment 9

15 years ago
Joshua, I think he did close all the windows. But quick launch still there so
the plugin will not be destroy.
(Assignee)

Comment 10

15 years ago
So this shouldn't be a bug, because JPI is still working when there is still
netscape instance 
(Reporter)

Comment 11

15 years ago
I think this bug should be closed, and I don't know who is in charge of doing
it. I reported this bug, but since Mozilla 1.1 (I think) when the last window is
closed (and last window can be browser, mail, download manager, etc.), quick
launch is restarted (actually restarting mozilla) and thus, killing the java
console and freeing up memory.
I tested this in W2000; I don't know about the other platforms

Regards

Comment 12

15 years ago
Unix platforms don't have quick launch. But I'm not sure Mac

Comment 13

15 years ago
Closing per comment 10
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.