Closed Bug 1048230 Opened 6 years ago Closed 6 years ago

Global indicator inaccessible when taskbar is on top of the screen

Categories

(Firefox :: Site Permissions, defect)

34 Branch
All
Windows 7
defect
Not set
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 34
Iteration:
34.3
Tracking Status
firefox33 --- verified
firefox34 --- verified

People

(Reporter: bogdan_maris, Assigned: florian)

References

Details

Attachments

(1 file)

Reproduced using latest Nightly 34.0a1

STR:
1. Open Firefox
2. Set media.getusermedia.screensharing.enabled to true
3. Open http://queze.net/goinfre/ff_gum_test.html in a new tab
4. Click Audio & Video
5. Click Share Selected Devices
6. Move the taskbar from down to UP

Expected result: The indicator stays above the taskbar and it can be accessed.

Actual result: The indicator stays under the taskbar and it can`t be accessed.

Notes: 
1. This is Windows only, I did not manage to move the 'taskbar' on ubuntu.
2. Screenshot showing the issue: https://db.tt/BNIcJwTa
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)

> 1. This is Windows only, I did not manage to move the 'taskbar' on ubuntu.

bug 1041675 seems the Linux equivalent.

I wonder if the solution here wouldn't be to use screen.availTop instead of 0 when positioning the indicator.
Flags: firefox-backlog+
Comment on attachment 8474499 [details] [diff] [review]
Display the window at y=availTop instead of 0

Seems ok. Is there a reason the popup is locked vertically? You might consider removing all the custom window dragging code and just using WindowDraggingUtils.jsm
Attachment #8474499 - Flags: review?(enndeakin) → review+
Hi Florian, can you provide a point value and if the bug should be marked as [qa+] or [qa-].
Assignee: nobody → florian
Status: NEW → ASSIGNED
Iteration: --- → 34.2
QA Whiteboard: [qa?]
Flags: needinfo?(florian)
(In reply to Neil Deakin from comment #3)
> Is there a reason the popup is locked vertically?

Because UX (phlsa) said so.

> You might
> consider removing all the custom window dragging code and just using
> WindowDraggingUtils.jsm

We (Gijs) actually started from WindowDraggingUtils.jsm and forked it to implement the requested UX.
Points: --- → 2
QA Whiteboard: [qa?] → [qa+]
Flags: needinfo?(florian)
Blocks: 1040061
Whiteboard: [screensharing-uplift]
Iteration: 34.2 → 34.3
QA Whiteboard: [qa+]
Flags: qe-verify+
https://hg.mozilla.org/mozilla-central/rev/9ac5e34bd1f5
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Verified that if a call is made with taskbar on top it the global indicator will show under the taskbar not behind it. Tested on Windows 7 64bit and Windows 8.1 Microsoft Surface PRO, using latest Nightly 34.0a1.
Status: RESOLVED → VERIFIED
Comment on attachment 8474499 [details] [diff] [review]
Display the window at y=availTop instead of 0

Approval Request Comment
[Feature/regressing bug #]: bug 1037408
[User impact if declined]: Windows users with the taskbar at the top of the screen may be unable to use the global webrtc sharing indicator that would be covered by the task bar.
[Describe test coverage new/current, TBPL]: currently on m-c, verified by QA.
[Risks and why]: Low, tiny self-contained code change.
[String/UUID change made/needed]: none.
Attachment #8474499 - Flags: approval-mozilla-aurora?
Attachment #8474499 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1041675
Whiteboard: [screensharing-uplift]
Also verified this using latest Aurora 33.0a2 on Windows 7 64bit and Windows 8.1 Microsoft Surface Pro.
Component: WebRTC → Device Permissions
Product: Core → Firefox
Target Milestone: mozilla34 → Firefox 34
You need to log in before you can comment on or make changes to this bug.