If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ABBR and ACRONYM should not have arrow/question cursor

VERIFIED FIXED in mozilla1.0

Status

()

Core
Layout
P4
normal
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Tim Powell, Assigned: Biesinger)

Tracking

({polish})

Trunk
mozilla1.0
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
The ABBR and ACRONYM elements should not use the arrow/question help cursor. As 
I mentioned in bug 97839, every other place I've seen that cursor pointer used 
it means you can click to get help information. In the case of these tags it 
only provides a tooltip after hovering for a while (clicking does nothing), so 
it's confusing to have that pointer. The pointer should be eliminated. There's 
already special dotted border underlining to indicate that it's special text.

If possible, it'd be better if the tooltip was triggered immediately (or more 
quickly) on mouse over for these elements. This would be clearer than having 
the mouse pointer change. The pointer change is especially confusing when over 
a link, because users may expect the link to take them to more information 
about the ABBR or ACRONYM.

Comment 1

16 years ago
reporter: what os are you running? Our PC OS List is supposed to be complete.

Comment 2

16 years ago
I've seen this behavior on Windows 2000 Pro, and on Windows 98. My guess would
be that this behavior is exhibited regardless of platform, but I could be wrong
about that. Can anyone on other platforms (Linux, Mac, etc.) confirm?
(Reporter)

Comment 3

16 years ago
Strange... I'm running WinNT 4.0 SP 6. I didn't even think to look. Perhaps IE 
5 used to submit this bug didn't identify it as expected? 

I don't know if other platforms use the same arrow/question cursor or have 
different platform-specific behavior, so I updated the OS to be WinNT. This may 
have the same UI impact on all platforms, though.
OS: other → Windows NT
Linux uses the 'questionable' cursor as well...
OS: Windows NT → All

Comment 5

16 years ago
ah, hrm. i recently checked in a fix for bugzilla for that, it's possible that 
bugzilla hasn't tippified since i made that change, i'll email you a question 
to see if we can sort that out.

Comment 6

16 years ago
Yeah, this is a reasonable complaint. The question cursor is only ever used for
the `What's This?' function, which requires a click, whereas we're using it for
something else which doesn't require a click. So we're just being confusing.

--> Layout. This is probably a one-liner fix in html.css.
Assignee: mpt → attinasi
Component: User Interface Design → Layout
Keywords: polish
QA Contact: zach → petersen
This is indeed a one-liner, but what should the cursor be? Just the default
arrow cursor?
Should probably be |auto| (or removed completely) for now since nothing else
fits the bill.  hard-coding it to |default| could be bad...  Think
<a><abbr></abbr></a>
Of course.  My question was:  Should <abbr> and <acronym> affect the cursor in
any way or should it be determined as it would be normally if the <abbr> and
<acronym> are not present?

Comment 10

16 years ago
Just leave the cursor as it would be normally.
Created attachment 78589 [details] [diff] [review]
patch

imho, we should act as if the abbr wouldn't be there

patch to do this
Created attachment 78590 [details] [diff] [review]
patch

imho, we should act as if the abbr wouldn't be there

patch to do this
for some reason that patch doesn't work.... I still get the help cursor....
...because the page I tested is on crack and explicitly sets the help cursor.

r=caillon
taking bug

Assignee: attinasi → cbiesinger
Priority: -- → P4
Hardware: PC → All
Target Milestone: --- → mozilla1.0
ccing attinasi since this bug was originally assigned to him
Status: NEW → ASSIGNED

Comment 17

16 years ago
I like the help cursor, that is why I put it in there in the first place. If you
remove it here, somebody will just open a bug that it regressed and should be
put back. This is a personal-taste and opinion issue. 

Comment 18

16 years ago
No, I'm afraid it is not a taste or opinion issue. That is not the function of
that cursor. You may wish that the cursor had another meaning and function, but
it has the meaning and function that it has.

Comment 19

16 years ago
And this is formalized in what cursor edict?

Comment 20

16 years ago
Sorry for being a smart-ass in my last comment. I do not believe that cursors
have immutable meanings, though I'd agree that they do have practical meanings
based on conventional wisdom and usage.

Comment 21

16 years ago
I should apologize, too. I'm not a developer, and I'm not a UI designer. I'm
just a power user who knows too much for his own good. If I were either of those
two, it would not have taken me so long to track down this one reference, which
is unfortunately platform specific.

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnwue/html/ch13c.asp

Look for Context Sensitive Help. It gives very specific instructions on how this
cursor is to be used.

I found this by following one of the User Interface Design bookmarks that ships
with Mozilla. Obviously, it is going to be slanted toward Microsoft
environments. As I said, I'm not a developer or a UI designer, so I'm afraid I
can't draw on a wealth of knowledge for what is appropriate for various
platforms. However, a simple search for similar documents in other environments
(such as the Macintosh Human Interface Guidelines) will yield similar
information for those platforms.

Comment 22

16 years ago
'Know what? I really don't care. sr=attinasi for the change - have at it.
Comment on attachment 78589 [details] [diff] [review]
patch

marking r=caillon sr=attinasi
Attachment #78589 - Flags: superreview+
Attachment #78589 - Flags: review+
checked in on trunk
leaving open for branch checkin
Comment on attachment 78589 [details] [diff] [review]
patch

a=dbaron for 1.0 branch checkin
Attachment #78589 - Flags: approval+
checked into branch, marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 27

16 years ago
So, has anyone opened a regression bug 'ABBR and ACRONYM elements should have
arrow/question cursor' yet? Let me know if you want me to do it ;-)
> So, has anyone opened a regression bug 'ABBR and ACRONYM elements should have
> arrow/question cursor' yet? Let me know if you want me to do it ;-)

Heh, not AFAIK.  However that could be a result of the fact that this really
hasn't been checked in into the branch yet.  Unfortunately, just commenting
'checked into branch' doesn't trigger CVS to automatically check in the correct
patch.  Would be nice though...  :)

Anyway, too bad there isn't a cursor which is an arrow with an exclamation point
or something... I wouldn't mind seeing something like that for abbr and acronym.
(but I'm no cursor expert).  In the meantime, I'm reopening because this
particular 'bug' still isn't fixed...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
looks like I did check into the branch, just the wrong one - I used 
MOZILLA_1_0_BRANCH...
(http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=MOZILLA
_1_0_BRANCH&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby
=Date&hours=2&date=day&mindate=&maxdate=&cvsroot=%2Fcvsroot)

will check into correct branch later
However, "cvs update -r MOZILLA_1_0_0_BRANCH html.css" and
http://lxr.mozilla.org/mozilla1.0/source/layout/html/document/src/html.css#342
show that this is also fixed on the correct brach.

marking fixed again.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 31

16 years ago
adding fixed1.0.0 keyword for branch resolution.
Keywords: fixed1.0.0

Comment 32

16 years ago
*** Bug 144125 has been marked as a duplicate of this bug. ***

Comment 33

16 years ago
Verified in the May 21 build (2002-05-21-08).
Status: RESOLVED → VERIFIED

Comment 34

16 years ago
Verified on OS X 2002-05-19-05 branch and Windows ME 2002-05-22-08 branch.
Keywords: verified1.0.0
You need to log in before you can comment on or make changes to this bug.