Settings icon is missing from Reviewer Tools in portrait mode

RESOLVED WONTFIX

Status

Marketplace
Reviewer Tools
P5
normal
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Victor Carciu, Unassigned)

Tracking

Avenir
x86_64
Android
Points:
---

Details

(Whiteboard: [marketplace-transition])

(Reporter)

Description

3 years ago
Prerequisites:
Android 4.3(Galaxy S3), Latest Nightly for Android installed

Steps to reproduce:
1.Open MP Stage and login with valid credentials
2.From Settings go to Reviewer Tools

Expected results:
A Settings icon is displayed on top right side of the screen in both portrait and landscape modes

Actual results:
Settings icon is missing in Portrait mode

Please see screencasts for this bug :

Portrait : http://screencast.com/t/FphSF8WUQtYU
Lanscape : http://screencast.com/t/X7F7rG8IHqt
This is working as expected [1]. I'm not sure why it was hidden but it looks like it was originally hidden by 96a73d7 [2]. Davor, do you have any insight on this?

[1] https://github.com/mozilla/zamboni/blob/master/media/css/devreg/reviewers-mobile.styl#L417-L419
[2] https://github.com/mozilla/zamboni/commit/96a73d74a5369c13b9c2b812af253283fd8f784d
A couple of things here. From what I remember that was a hover nav so not sure it makes any sense on mobile...granted I know in reviewer tools we made many such former hover interactions spawn a modal (with choices) on tap. If so the gear icon should be re-added to portrait mode. I also think the account options were a text link back then and the header didn't have room - but that's guessing also.

tldr: We likely need account options available on mobile (both orientations) but make sure the existing settings trigger does something meaningful on mobile.

Updated

3 years ago
Priority: -- → P5
Target Milestone: 2014-08-05 → ---

Updated

3 years ago
Duplicate of this bug: 1091632

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [marketplace-transition]
You need to log in before you can comment on or make changes to this bug.