Design generic business cards for Firefox OS release in France

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: flore, Assigned: Jennifer Balaco)

Tracking

Details

(Reporter)

Description

4 years ago
We want to design a kind of business card to give to give away to people in the street and in the shop where the phones will be sold.

On one side: the logo and our hashtag for the release: #FirefoxOSfr
On the other side: a link to the Firefox OS page on mozfr.org where we will put all the relevant links for Firefox OS in France (support, social network pages, etc.). Perhaps also a QR Code to go easily to the URL.

We need to know which logo should be used on this business card (blueprint or colored fox).

This will be a generic business card, no particular name, only mozfr links. In fact, it's just the format of the business card.

Comment 1

4 years ago
Hey Flore!
I dont know if you have heard about it, but we are developing an unified system for Business Cards among Mozilla. I was thinking maybe we could create Firefox OS Launch business cards with similar templates as those for Reps, Mozillians and FSA?

Here is the thread on Reps General:
https://groups.google.com/forum/#!topic/mozilla.reps.general/mgizEAt05so

and a preview of the business cards workflow:
https://docs.google.com/presentation/d/1-CDwkkEIdJ74VtBDqPfypYMq1onUeCE4EUJx-HRXJo0/edit#slide=id.g365bdd483_071

I saw that there were also some stickers available for the countries which have already launched Firefox OS.
Cant find them right now but I will post it once I found it

Would love to hear the opinion of John or Sean ( if youre not on vacation guys)

Comment 2

4 years ago
Hi all,

Thanks for filing this. John is on vacation, but I can provide some more information.

To address comment 1, it sounds like these are more like small postcards or pass-along cards than business cards. We actually have a lot of materials and resources we can provide you for launch activities in your country. I've added Jessica Osorio to this bug who can give you more details about all those kinds of things.

Jessica, please have a look at the bug and let me know how we can help.
Flags: needinfo?(josorio)
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 3

4 years ago
(In reply to Matej Novak [:matej] from comment #2)
> Hi all,
> 
> Thanks for filing this. John is on vacation, but I can provide some more
> information.
> 
> To address comment 1, it sounds like these are more like small postcards or
> pass-along cards than business cards. We actually have a lot of materials
> and resources we can provide you for launch activities in your country. I've
> added Jessica Osorio to this bug who can give you more details about all
> those kinds of things.
> 
> Jessica, please have a look at the bug and let me know how we can help.

Exactly, pass along cards is what I wanted to say. I said business cards because of the format. I will see with Jessica!
Thanks a lot Matej

Comment 4

4 years ago
I just remembered that we also have these: https://bug880519.bugzilla.mozilla.org/attachment.cgi?id=774375 (created in bug https://bugzilla.mozilla.org/show_bug.cgi?id=880519)

We may be able to repurpose that design here, but I'll let Jessica weigh in on what's possible.

Comment 5

4 years ago
Awesome! Thank you Matej!
Guys, just give me a call and I can do whatever changes you need; this should be pretty straightforward.
(Reporter)

Comment 6

4 years ago
Thanks Matej! It would be wonderful. However I don't know if the printing facility we chose will allow us to have 2 colored sides. But we can try.
I wait for Jessica's advice on this and I'll see with elio for design and technical help.

Thank you so much!!!
Hello Flore! 

Those assets that Matej provided are perfect! If the printing company you find doesn't allow two colored sides than we can look into eliminating the end of the flaming tail on the back and only leaving the relevant links/URLS all in black and white on that one side. 

Matej: Would that be ok or would that go against brand guidelines? 

Flore: I would love to know more about those destinations your were mentioning that you want to drive people to. Only because in the past we've always driven people to our Firefox OS site and if we want to drive to the France page specifically that would be great too: http://www.ztefrance.com/firefox-open-c.php. 

Thank you!
Flags: needinfo?(josorio)
Flags: needinfo?(Mnovak)
Flags: needinfo?(Flore)

Comment 8

4 years ago
I agree that with these official launch materials we should be pointing to the official Firefox OS sites, but I think we could find a way to add the hashtag for the France launch.

We could also make some tweaks to the back of the card, but it would be ideal if it could still be blue.

Flore, are there any other printers you could work with? I'm sure someone in the Paris office could put you in touch with someone they've used in the past.

One thing I forgot to ask about was deadline. When do you need these by?
Flags: needinfo?(Mnovak)
(Reporter)

Comment 9

4 years ago
OK I just checked with the printer and it's okay for the visit cards as it is. No need to change the background. We just need to change the text:
Look ahead => Regardez l'avenir
For the URL, it would be a landing page (not yet done), probably http://firefoxos.mozfr.org/ (to be confirmed)
where we would regroup the useful links to our french users, for example:
http://forums.mozfr.org/viewforum.php?f=35
The links to our social network accounts (twitter, facebook, diaspora, google+)
http://www.ztefrance.com/firefox-open-c.php
Links to where to buy the phones, commercial offers.
Informations that are relevant to the french users not only to prospective customers.
It would be a page that we can update regularly and easily.

The deadline would be to get the file by monday (Europe) to get it printed for our events in Leclerc by the end of august.
Flags: needinfo?(Flore)
Brian: 
Flore would like to create pass-along cards for the France launch events/activities that will drive people to a landing page with useful links related to FXOS(FR) but we'd like to clarify a few things first...

Do you know if we're already handing out any flyers or cards at these events that will drive to any other related FXOS landing pages? 

Also, we have some great assets we can use (Matej posted here): https://bugzilla.mozilla.org/show_bug.cgi?id=1048361#c4
-- But if we're directing to a community-created landing page we will need to go with the blueprint FXOS look and feel as the flaming fox and cyan blue is reserved for official Firefox OS branding needs. 

Flore: 
We want to make sure we're not driving people to too many pages (that's why I'm asking Brian if we're already thinking of passing out flyers or stickers with the official FXOS site URL). 

Before we make any design decisions we need to see the final landing pages in order to recommend the correct/approved look and feel of the cards. 

Flore would you be open to driving to the official FXOS page and just the Community Channels, where you can then promote the other useful links (on those social channels)? 

Please confirm at your earliest convenience. 

Thanks all! 

-Jess
Flags: needinfo?(bking)
Flags: needinfo?(Mnovak)
Flore, I meant to say I need info from you in my previous comment. :)

Thank you
Flags: needinfo?(Mnovak) → needinfo?(Flore)
(Reporter)

Comment 12

4 years ago
Jessica, we will of course give away the official flyer (that has been translated to french): https://www.dropbox.com/s/sc2jdtaweaezo4q/FireFox%20DL%20Leaflet_French%231.pdf

Basically, flyers direct people to a page that answers the question "What is Firefox OS?"
Our cards direct people to a page that answers the question "I need help, where can I get it?"

So when people will ask "If I have a problem with my phone, where can I get some help?" we will give them those small cards and they will be happy knowing taht they will find help. Otherwise, we would have to tell them "write down the URL" or "Search on google", clearly it's not what they want to hear.
We have needed that type of card for many years, when we told people to install Firefox on their computers. We have never been able to make them (because of the costs), we sometimes printed some papers before an event, but it ran out really fast...

Our main resource is forums.mozfr.org
Some people would also like to get answers on twitter or facebook, that's why they will be mentioned.
Flags: needinfo?(Flore)
Thanks, Flore. That really helps me understand the request better. I think given all that information, these should use the blueprint fox because all the links and info point at the community.

Elio, would you still have time to help with this?
Flags: needinfo?(helios)

Comment 14

4 years ago
Yes, I'm available in the coming days/weeks, just let me know what we will decide on doing and it should be pretty straightforward to finish them.
Flags: needinfo?(helios)
I was just chatting with Ty, one of our designers (now CC'd), about getting the assets we would need for this and then suddenly, magically he sent me this: http://cl.ly/image/0w1617123O0K

Would that work for your needs?
(Reporter)

Comment 16

4 years ago
(In reply to Matej Novak [:matej] from comment #15)
> I was just chatting with Ty, one of our designers (now CC'd), about getting
> the assets we would need for this and then suddenly, magically he sent me
> this: http://cl.ly/image/0w1617123O0K
> 
> Would that work for your needs?

Wow, I already thought that you guys were magicians, but here is the proof!
It's truly perfect, thank you so much, Ty!
Can you attach the file to be sent to the printer? They accept files with the following extensions: JPG, PDF (version 1.3 or 1.4), TIFF, EPS, AI, PSD, GIF, PNG, BMP, DOC, PPT, ODT, ODG, SXD, ODP, ODS, XLS, RTF, EMF and WMF

Thank you Matej!
And Thank you Elio for helping me all along! Your work on visit cards is truly amazing, keep up the good work!
Hi,
this looks really fantastic !
I have a "cosmetic" comment : I like when we add the Facebook logo along the Facebook page and the twitter logo along the twitter name (we can use @firefoxosfr instead of #firefoxosfr, I don't know what's best ?). I think it's not so obvious to everyone that the hashtag means "twitter" (especially here in retail stores...)
(In reply to Natalia Martinez-Winter from comment #17)
> Hi,
> this looks really fantastic !
> I have a "cosmetic" comment : I like when we add the Facebook logo along the
> Facebook page and the twitter logo along the twitter name (we can use
> @firefoxosfr instead of #firefoxosfr, I don't know what's best ?). I think
> it's not so obvious to everyone that the hashtag means "twitter" (especially
> here in retail stores...)

Hi Natalia,

The request was for a website and hashtag, so in this case neither of them is a Twitter account or a Facebook page. The hashtag can be used on all kinds of social media, not just Twitter, so it's better to leave it as is.

Also, from Flore's description, it sounds like they'll be giving these cards to people after they've talked to them, so they'll already know what it all means. This will just serve as a reminder so they don't have to write anything down.

Ty, please go ahead and upload the files for the printer. Thanks again for your quick help.
Flags: needinfo?(tflanagan)

Comment 19

4 years ago
Here is the compressed EPS file to print the business-sized card with:

https://www.dropbox.com/s/8to5cjuvrrsxot5/FFxOS_BizCard_FR.eps.zip
(Reporter)

Comment 20

4 years ago
Hi Ty, thanks for uploading this file. I'm very sorry but I checked on our printer's site and they need 2 files (one for each side) and total not exceeding 24 MB.
See http://www.overnightprints.fr/main.php?A=uploader&new=1&p=bc

And also I noticed something that bothers me: the text "firefoxos.mozfr.org" appears on the right side of the card, instead of being centered. I'm not sure it should.

Can you check this for me? And upload 2 separate files?
Thanks again and sorry for the inconvenience.

Comment 21

4 years ago
Hang on Flore, Im doing the changes :)

Comment 22

4 years ago
Updated cards:
https://dl.dropboxusercontent.com/u/62482708/Mozilla/Assets/MozFR_Front.pdf
https://dl.dropboxusercontent.com/u/62482708/Mozilla/Assets/MozFR_Back.pdf

Seperated the designs to front and back. They're in CMYK PDF now and should be fine for print.
Fixed also the Mozilla and Firefox OS wordmarks, there were wierdly distorted.

Let me know Flore if these are okay!
Flags: needinfo?(Flore)

Comment 23

4 years ago
Thanks for separating them Elio.

The distortions you mentioned are infact design elements. Both the Firefox OS and mozilla wordmarks purposely had the same "sketch" treatment as the main tagline.

Comment 24

4 years ago
I know, but you can't do those treatments to logo wordmarks. Would be Heretism in design :)

Comment 25

4 years ago
Elio: It's not heretism, it's part of a living brand (not unlike Google doodles, MTV logo variants, etc) - a very common branding mechanism.

We should leave the look as Ty provided to keep consistent with the brand guidelines outlined here: https://www.mozilla.org/en-US/styleguide/identity/firefoxos/community/

Thanks!
(In reply to Sean Martell from comment #25)
> Elio: It's not heretism, it's part of a living brand (not unlike Google
> doodles, MTV logo variants, etc) - a very common branding mechanism.
> 
> We should leave the look as Ty provided to keep consistent with the brand
> guidelines outlined here:
> https://www.mozilla.org/en-US/styleguide/identity/firefoxos/community/

Not only should we, but we have to. That's the way that branding was designed and we can't alter it per use.

Thanks.

Comment 27

4 years ago
The Firefox OS and mozilla wordmark stylized with these strokes? I have never seen them used like this, even not in the style guide. I'm not sure if you understood what I meant well, but check both attachments please to see what I mean. The posters on the link you provided neither have brushed logo wordmarks in that way.
Flags: needinfo?(smartell)

Comment 28

4 years ago
So the posters on the style guide do have the same styling, but with them being resized, it is difficult to the see the sketch effect. 

I uploaded a graphic which does illustrate the sketch effect thats used on those posters a little better:
http://cl.ly/image/0V0Y2w3y0a0w
Ty, thanks so much for sharing these.

Elio, whether or not you've seen it before is not the point. This is the style we've established and it's critical that we follow it. Please confirm that you can (and will) revert it to the way Ty originally set up the file. Otherwise I'll have to ask someone from our team to do it.

Flore, please hold off on sending these files to the printer until this is sorted out.
Flags: needinfo?(tflanagan)
Flags: needinfo?(bking)
(Reporter)

Comment 30

4 years ago
> Flore, please hold off on sending these files to the printer until this is
> sorted out.

I wrote a comment yesterday but he was destroyed by a mid air collision, apparently and I did not notice.

I'm waiting for this issue to be solved before sending any file to be printed. I will use the design that is approved by mozilla creative team.
As I said previously, my deadline is on monday, so I'm not so much in a hurry.
Flags: needinfo?(Flore)

Comment 31

4 years ago
Sorry guys, I wasn't intending to justify myself, I was just not aware at all of this style element ( and I was sure I studied the style guide pretty well)
My apologies for that.

I updated the cards with the same wordmarks by Ty, so they should be correct now.
They are the same links as before:

https://dl.dropboxusercontent.com/u/62482708/Mozilla/Assets/MozFR_Front.pdf
https://dl.dropboxusercontent.com/u/62482708/Mozilla/Assets/MozFR_Back.pdf

Let me know if something is missing.
Flags: needinfo?(smartell)
(Reporter)

Comment 32

4 years ago
Thank you for your help, Elio.

Matej or Ty, can you confirm these new files are okay and wa can use them?

Thanks again everyone for your help ;)
Flags: needinfo?(tyronflanagan)
Flags: needinfo?(Mnovak)
Thanks, Elio.

It looks good to me, but let's wait until Ty has had a chance to review before we call it final.
Flags: needinfo?(Mnovak)

Comment 34

4 years ago
Thanks all,

One thing - Flore, Did you say that the maximum file limit size is 24mb for both? If so, we might need to provide a different file type as the PDF for the front of the card is over 24mb.

Other than that, the designs are good to go.
Flags: needinfo?(tyronflanagan)
Excellent work! I can see these being in demand by other communities. Elio, please post the source files somewhere.
(In reply to Ty Flanagan from comment #34)
> Thanks all,
> 
> One thing - Flore, Did you say that the maximum file limit size is 24mb for
> both? If so, we might need to provide a different file type as the PDF for
> the front of the card is over 24mb.
> 
> Other than that, the designs are good to go.

Flore, can you confirm if the size is OK?
Flags: needinfo?(Flore)

Comment 37

4 years ago
Thanks Brian!
I posted them on the Reps Facebook group, probably can also write a post on Reps General.
(Reporter)

Comment 38

4 years ago
The site states "The combined size of your files should not exceed 24 MB." I tried to upload them anyway and I got another information: a single file can not exceed 20MB.
So if you can make the front side smaller than 20MB, it would be great!
Flags: needinfo?(Flore) → needinfo?(helios)
(In reply to Brian King [:kinger] from comment #35)
> Excellent work! I can see these being in demand by other communities. Elio,
> please post the source files somewhere.

(In reply to Elio Qoshi  [:Elio] from comment #37)
> Thanks Brian!
> I posted them on the Reps Facebook group, probably can also write a post on
> Reps General.

Unfortunately it's not so simple with this one. The type in that file isn't editable, so it couldn't be localized. The issue is that the type treatment isn't a font, it's a custom thing that Ty created and applies manually each time — and this blueprint style relies on it (i.e. it can't exist without it).

I'll see if there's something we can do to make these more easily editable, but for now we'll have to handle requests for these individually.

Sorry about that. This one came in and got done so fast we weren't thinking beyond it. Hopefully we can figure something out that makes it easier for everyone.
(In reply to Flore Allemandou [:flore] from comment #38)
> The site states "The combined size of your files should not exceed 24 MB." I
> tried to upload them anyway and I got another information: a single file can
> not exceed 20MB.
> So if you can make the front side smaller than 20MB, it would be great!

I was just chatting with Ty and he says that converting it to TIFF may do the trick.

Elio, could you give that a try? Thanks.

Comment 41

4 years ago
I was thinking the same Matej just after I posted them, the brush strokes are hardly localizable in an automatic way. 

Individual should work too though. I can create those in 95% of the cases if Im notified 3 days before theyre needed. So people can have that in mind.

Checking now for TIFF
Flags: needinfo?(helios)

Comment 42

4 years ago
Saved it as EPS instead. Should work too, it's 18.6mb
https://dl.dropboxusercontent.com/u/62482708/Mozilla/Assets/MozFR_Front.eps

Flore, let me know if this works for you.
Flags: needinfo?(Flore)
(Reporter)

Comment 43

4 years ago
Hello Elio, that's OK for me!
Thanks a lot, everyone for your help on this :)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(Flore)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.