[Flame] [Video] Very difficult to video white screens on device due to extreme backlighting

RESOLVED DUPLICATE of bug 1051200

Status

Firefox OS
Vendcom
RESOLVED DUPLICATE of bug 1051200
3 years ago
3 years ago

People

(Reporter: marcia, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8467247 [details]
2014-08-04-12-20-55.png

[Blocking Requested - why for this release]: End users should be able to videotape anything without extreme backlighting.

Flame, while running:

Gaia   9e5907995c9327f14cb5d182cee5ff16b1743ed4
SourceStamp 3f7db58a354c
BuildID 20140804000204
Version 32.0
Base image: 123

STR:
1. Using another Flame device, open up the settings app so that a white screen is showing.
2. Open the Camera app on another Flame device, and point it at the screen and try to record it.

Expected: I could record the screen and would be able to see the text in the settings app
Actual: I cannot see anything but white glare and extreme backlight

Will test on v122 and see if it worked there. On the ZTE Open C with a current build there is some backlighting, but not as extreme as on the Flame.
(Reporter)

Comment 1

3 years ago
This issue doesn't occur on v122, so I think it is a Vendcom issue.
Component: Gaia::Video → Vendcom
QA Wanted to check if this reproduces on the v123 base image.
Keywords: qawanted
QA Contact: jmercado
I misunderstood the qawanted request upon first starting this and ended up checking more than requested.  What I found was that neither the 122 or 123 base image alone reproduced this issue, but I was able to reproduce this using both bases on the latest 2.1 Flame build.

Environmental Variables:
Device: Flame Master
BuildID: 20140805074901
Gaia: e93780f9da8b34f370a4113abd4df9780d58e443
Gecko: 1aab16f74817
Version: 34.0a1 (Master) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Can we do more branch checks here to see if this is a regression?
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
QA Contact: jmercado → ckreinbring
Able to repro on Flame 2.0, Flame 1.4 and Open C 2.1
Actual result: While another Flame's settings page is in the DUT's video recording viewfinder, the screen will be unreadably bright if the DUT is about a foot away.

Flame 2.0
Build ID: 20140806084615
Gaia: 47fa0ba8197e71cc7034943ff037642e7f35cdfe
Gecko: 4feed2803746
Platform Version: 32.0
Firmware Version: V122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 1.4
Build ID: 20140806081546
Gaia: e9dce1f60f729e228810f751417681b5ff937b6b
Gecko: d281a3bdfea6
Platform Version: 30.0
Firmware Version: V122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Open C 2.1
Build ID: 20140806054320
Gaia: 5e6ef81cb9e917657ce050f598229dfc83c58b8f
Gecko: bdf301b20cab
Platform Version: 34.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

--------------------------------------------------------------------------------------------------------

The bug does not repro on Buri 2.1
Actual result: While another Flame's settings page is in the DUT's video recording viewfinder, the screen will not become unreadably bright at any distance.

BuildID: 20140806090025
Gaia: 5e6ef81cb9e917657ce050f598229dfc83c58b8f
Gecko: f41a267983c1
Platform Version: 34.0a1
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
Flags: needinfo?(jmitchell)
Keywords: qawanted
NI mike here to get his input before making a blocking call. Could this be a JB specific issue ?
Flags: needinfo?(mhabicher)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(In reply to bhavana bajaj [:bajaj] from comment #6)

> NI mike here to get his input before making a blocking call. Could this be a
> JB specific issue ?

This doesn't seem to happen with Flame/KK (v162-3). If I start recording and then point the camera at my very-black mousepad, then point it at either a window (it's very sunny outside) or the Settings screen of another Flame (with backlight set to maximum)--or vice-versa--the exposure automatically adjusts correctly.
Flags: needinfo?(mhabicher)
Created attachment 8471048 [details] [diff] [review]
WIP - expose exposure (heh) metering modes, v1

Flame reports some curious values:

 - metering modes: default mode 'frame-average', supported modes:
     'frame-average'
     'center-weighted'
     'spot-metering'
     'center-weighted'
     'spot-metering-adv'
     'center-weighted-adv'

No idea what the 'adv' modes are; not sure why there are two 'center-weighted' modes.
We've decided to not block on this because the use case in the bug isn't a regression & unlikely use case for a user to trigger.
blocking-b2g: 2.0? → backlog
See Also: → bug 1051200
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1051200
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.