Closed Bug 1048508 Opened 6 years ago Closed 6 years ago

Downloads scanner should provide user the option to save the potential harmful file

Categories

(Toolkit :: Downloads API, defect, major)

x86_64
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1062966

People

(Reporter: Optimizer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: uiwanted)

I was downloading the Firefox OS flatfish images from a trusted location [0] as provided by the wiki [1]. The wiki asks us to download the the whole folder as zip so the zip size was around 95 MB.

I am on a very slow internet (512 kbps) and the 94 MB took time to download, but at the very end, the scanner picked up the .sh file from the zip and blocked the complete zip.

I had to download the same file again after disabling the feature.

I think the blocker should first ask for the user's choice rather than simply blocking the whole download. What if the file size was more than 2-3 GB ? Thsi is not only wasting user's bandwidth, but also causes frustration as the (average) user (giving up after second try and not knowing a way to disable the feature) will switch to another browser and download the file. He may also completely switch due to the frustration caused (may be a couple of times in future again)


[0] https://www.dropbox.com/sh/b2py1btcwstqldl/AADO5bxKRXvA84IhLXr6PIBsa/20140804
[1] https://wiki.mozilla.org/FirefoxOS/TCP/Flashing_the_Flatfish_bootloader
I thought we didn't call the malware scanner anymore.
I dont know what we call, but I am referring to the work done in bug 662819
IMHO this is a blocker for the feature.
Keywords: uiwanted
Flags: firefox-backlog+
I was also bitten by this bug this morning and got quite annoyed since I got no indication whatsoever until I looked in the Download Manager window. And whatever we do, we shouldn't be this patronizing and simply not give the user a choice to download the file anyway. A warning is good, but interrupting people's workflow like this is just not acceptable, IMO.
OS: Windows 7 → All
As defined in Bug 1053890, we will add an "overrule" UI in bug 1062966.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062966
Flags: firefox-backlog+ → firefox-backlog-
You need to log in before you can comment on or make changes to this bug.