[B2G][System] "OK" and "Skip" button on the SIM PIN screen are cutoff with Software Home Button enabled

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Dean R. Gomez (DeanG), Assigned: Eli)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8467422 [details]
SIM_PIN.png

Description:
When a user starts their device and the user gets to the screen that prompts them to input a PIN for their SIM, the "Skip" and "OK" buttons will be cutoff. 

Pre-req: Have a SIM with a PIN.

Repro Steps:
1) Update a Flame to 20140728040209
2) Launch Settings app and enable the Software Home Button within developer settings.
3) Restart the device.
4) Once prompted to input SIM PIN, observe the screen.

Actual:
The "OK" and "Skip" buttons will be cutoff.
Expected:
The "OK" and "Skip" buttons will display clearly without being cutoff.

Environmental Variables:
Device: Flame 2.1 (319MB)
Build ID: 20140728040209
Gaia: 295967a0b824a355ae9d57fb08f3632ed2ad18dd
Gecko: a4dcfbebcb58
Version: 34.0a1 (Master) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Repro frequency: 5/5 - 100%
See attached: Logcat_SIM_PIN.txt, SIM_PIN.png
(Reporter)

Comment 1

4 years ago
Created attachment 8467423 [details]
Logcat_SIM_PIN.txt

Attaching logcat.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
This looks bad and is not ideal but the buttons are functional and the user can see what each button does so not nominating this 2.0?
(Reporter)

Comment 3

4 years ago
Updating the Firmware Version for the variable for the 2.1 Flame in Comment 0. The correct firmware version is v123.
Whiteboard: [systemsfe]
(Assignee)

Updated

4 years ago
Assignee: nobody → eperelman
Eli, is this a duplicate of bug 1048593? ie, can they be solved with the same code changes?
Flags: needinfo?(eperelman)
(Assignee)

Comment 5

4 years ago
According to my digging so far, it looks like they should be able to be solved with the same patch. The code that runs these buttons is the "gaia-button" component, so any dialogs using this component would likely be exhibiting this same problem.
Status: NEW → ASSIGNED
Flags: needinfo?(eperelman)
(Assignee)

Comment 6

4 years ago
Dean, could you please re-test this against latest master? I was able to replicate the issue at 295967a0b824a355ae9d57fb08f3632ed2ad18dd, but it seems to be resolved in master.
Flags: needinfo?(dgomez)
(Assignee)

Comment 7

4 years ago
:mhenretty, it turns out that while the two different issues are linked through some shared CSS, the root cause was not the same. Regardless, I have a patch already open against bug 1048593.
Adding qawanted for a reset since we are having trouble reproducing.
Keywords: qawanted

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
This bug does NOT reproduce on Flame 2.1

Unable to reproduce this bug on the latest Engineering or Nightly builds.

Repro: 0/10

Environmental Variables: Nightly Build
Device: Flame Master
BuildID: 20140820040203
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master) 
Firmware Version: v123
-------------------------------------------------
Environmental Variables: Engineering Build
Device: Flame Master
BuildID: 20140819225026
Gaia: df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko: ffdd1a398105
Version: 34.0a1 (Master) 
Firmware Version: v123
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(jmitchell)
Flags: needinfo?(dgomez)
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Created attachment 8479109 [details]
screenshot on update screen

Reopening.  i see the clipped buttons on the Install update screen.

See screenshot.

1) install 8/25 2.1 nightly build on flame

Gaia      e424c85eda87a40c0fa64d6a779c3fa368bf770b
Gecko     https://hg.mozilla.org/mozilla-central/rev/daa84204a11a
BuildID   20140825040204
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230

2) enable soft home button in settings
3) settings > Device info> check for updates
4) find an update, and apply it via the status bar
5) when update is completed downloading, verify the install update screen is covered.

Expected:
- buttons are not covered

ActuaL:
- buttons covered

Updated

4 years ago
Blocks: 1036339
Status: RESOLVED → REOPENED
blocking-b2g: --- → 2.1?
Resolution: WORKSFORME → ---

Updated

4 years ago
Assignee: eperelman → nobody

Updated

4 years ago
Duplicate of this bug: 1054716

Updated

4 years ago
Assignee: nobody → eperelman
Summary: [B2G][System] "OK" and "Skip" button on the SIM PIN screen are cutoff with Software Home Button enabled. → [Soft Home Button] Several areas (marketplace, update screen) of buttons are covered up
(Assignee)

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
Summary: [Soft Home Button] Several areas (marketplace, update screen) of buttons are covered up → [B2G][System] "OK" and "Skip" button on the SIM PIN screen are cutoff with Software Home Button enabled
blocking-b2g: 2.1? → ---
You need to log in before you can comment on or make changes to this bug.