Incorrect value in "app.update.battery-threshold.plugged" and "app.update.battery-threshold.unplugged" are allowed

VERIFIED FIXED

Status

Firefox OS
Gaia::System
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: lolimartinezcr, Assigned: salva)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Tested
Flame
2.1
Gecko-c60b44a
Gaia-ab8f1eb

Reproducible: 100%

STRs:
Modify "app.update.battery-threshold.plugged" and "app.update.battery-threshold.unplugged" in " build/config/common-settings.json" file and write an invalid value (for example: 866666666666666)

Actual result:
Allow invalid value in this properties.

Expected result:
*Not* Allow invalid value in this properties. (Valid values: 0 - 100)
Assignee: nobody → salva
As a continuation of bug 1048201, asking for blocking flag.
blocking-b2g: --- → 2.0?
(In reply to Salvador de la Puente González [:salva] from comment #1)
> As a continuation of bug 1048201, asking for blocking flag.

Sorry, this is a continuation of bug 1034735.
Created attachment 8467697 [details] [review]
If the threshold exceeds the range [0, 100], the default values are taken instead.
Attachment #8467697 - Flags: review?(etienne)
Backlog since this is unrealistic for a partner to do with their build (i.e. setting the pref to an invalid value).
blocking-b2g: 2.0? → backlog
Comment on attachment 8467697 [details] [review]
If the threshold exceeds the range [0, 100], the default values are taken instead.

lgtm
Attachment #8467697 - Flags: review?(etienne) → review+
master: e9dc30188b535fd5adb0a47fb9d72d188c9c1bc6
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

4 years ago
Tested and working
Flame
2.1
Gecko-d5a4ba9
Gaia-80a41e0
Status: RESOLVED → VERIFIED
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.