Talos shouldn't replace "FATAL ERROR:" with "FATAL ERR_R:"

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: emorley, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
Broken out from bug 1026970 comment 25.

https://tbpl.mozilla.org/php/getParsedLog.php?id=45190486&tree=Try
12:05:02     INFO -  08-04 12:04:57.617 I/Gecko   ( 2191): FATAL ERR_R: Non-local network connections are disabled and a connection attempt to safebrowsing.google.com (173.194.33.46) was made.

We shouldn't replace the "FATAL ERROR" with "FATAL ERR_R", since it prevents TBPL from highlighting the line.

This is due to:

https://hg.mozilla.org/build/talos/file/59268b19aadf/talos/run_tests.py#l119
   119 def print_logcat():
   120     if os.path.exists('logcat.log'):
   121         f = open('logcat.log')
   122         data = f.read()
   123         f.close()
   124         for l in data.split('\r'):
   125             # Buildbot will mark the job as failed if it finds 'ERROR'.
   126             print l.replace('RROR', 'RR_R')

...which was added by bug 754873.

We should either:
1) Tweak the regex above to ignore the fatal error case.
2) Fix the root cause: buildbot should be using the harness return code (or at the least, less flaky regex) to avoid false positives.
See Also: → 1196287
Hmm, bug 1196287 removed that part of the code, so I think this bug can be closed.

Please reopen it if I'm missing something.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.