The repo 'mozilla-b2g/B2G' is not handled by sources.xml

RESOLVED WONTFIX

Status

Firefox OS
GonkIntegration
--
blocker
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: emorley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
In bug 1048819, the Hamachi nightlies started failing on mozilla-b2g30_v1_4, due to these commits landing:
https://github.com/mozilla-b2g/gonk-misc/commit/2249037c79fda1d2eede2d085716577d5357e796
https://github.com/mozilla-b2g/B2G/commit/388c52a88598d394421a8311f356976fd7065adc

Neither of these commits appeared as B2G bumper bot commits in mozilla-b2g30_v1_4's sources.xml files, making it extremely hard to see what regressed the builds.

We must make sure these two repos (and any others used as part of the build) are listed in sources.xml) are handled by sources.xml and the B2G bumper bot, since currently this does not meet the job visibility requirements:

https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy#8.29_Must_avoid_patterns_known_to_cause_non_deterministic_failures
" Must avoid pulling the tip of external repositories as part of the build - since landings there can cause non-obvious failures. If an external repository is absolutely necessary, instead reference the desired changeset from a manifest in mozilla-central (like talos or gaia do)."

I'm happy to leave these jobs (device image builds) visible for now, but this will need to be fixed in the next few weeks for them to remain shown by default.
(Reporter)

Comment 1

4 years ago
Chris, I don't suppose you could take a look at this?
Flags: needinfo?(catlee)
(Reporter)

Comment 2

4 years ago
gonk-misc is fine, it's just mozilla-b2g/B2G
Summary: B2G repos ''mozilla-b2g/gonk-misc' and ''mozilla-b2g/B2G" are not handled by sources.xml → 'mozilla-b2g/B2G is not handled by sources.xml
(Reporter)

Updated

4 years ago
Summary: 'mozilla-b2g/B2G is not handled by sources.xml → The repo 'mozilla-b2g/B2G' is not handled by sources.xml
I'm not sure what to do with the B2G repo, as this is currently not versioned or branched by anybody.

If there is currently bustage caused by this, then it should be backed out.

I also suggest a thread on dev-b2g about how to handle commits to this repo.
Flags: needinfo?(catlee)
(Reporter)

Comment 4

4 years ago
(In reply to Chris AtLee [:catlee] from comment #3)
> I'm not sure what to do with the B2G repo, as this is currently not
> versioned or branched by anybody.
> 
> If there is currently bustage caused by this, then it should be backed out.

That won't work, since the problem is that a particular landing required changes to two repos (B2G and gonk-misc) - where one of these repos is handled by sources.xml and the other not.

> I also suggest a thread on dev-b2g about how to handle commits to this repo.

Just to be clear - I'm not proposing us pinning to a fixed revision - it would just be great if b2g-manifest just tracked master of this repo, and so we would have the B2G bumper bot commits for visibility. As such, it wouldn't affect developer workflow. That said, we need to work out whether we should have master/2.x/1.x branches on mozilla-b2g/B2G or if the B2G bumper bot for gecko release branches should just track master of B2G too.
Blocks: 1089953
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.