B2G opt mochitest-6 failure with only "Return code: 1" present in the brief log

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: emorley, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

+++ This bug was initially created as a clone of Bug #1048080 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=45224618&tree=B2g-Inbound

23:18:56     INFO -  08-05 06:17:03.598 I/GeckoDump(  757): ⰲ겿{"action":"log","time":1407219423598,"thread":"","pid":null,"source":"mochitest","level":"INFO","message":"MEMORY STAT residentFast after test: 39485440"}ⰲ겿
23:18:56     INFO -  08-05 06:17:03.608 I/GeckoDump(  757): ⰲ겿{"action":"log","time":1407219423615,"thread":"","pid":null,"source":"mochitest","level":"INFO","message":"MEMORY STAT heapAllocated after test: 18831488"}ⰲ겿
23:18:56     INFO -  08-05 06:17:03.728 I/Gecko   (  875):
23:18:56     INFO -  08-05 06:17:03.728 I/Gecko   (  875): ###!!! [Child][MessageChannel] Error: Channel closing: too late to send/recv, messages will be lost
23:18:56     INFO -  08-05 06:17:03.728 I/Gecko   (  875):
23:18:56     INFO -  08-05 06:17:04.049 I/GeckoDump(  757): ⰲ겿{"action":"test_end","time":1407219424051,"thread":"","pid":null,"source":"mochitest","test":"/tests/dom/ipc/tests/test_NuwaProcessDeadlock.html","status":"OK","message":"Finished in 26589ms","extra":{"runtime":26589}}ⰲ겿
23:18:56     INFO -  08-05 06:17:04.668 E/GeckoConsole(  757): [JavaScript Warning: "The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it." {file: "http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html" line: 0}]
23:18:56     INFO -  08-05 06:17:04.929 I/GeckoDump(  757): ⰲ겿{"action":"test_start","time":1407219424918,"thread":"","pid":null,"source":"mochitest","test":"/tests/dom/ipc/tests/test_child_docshell.html"}ⰲ겿
23:18:56     INFO -  08-05 06:17:06.688 I/ServiceManager(   33): service 'media.resource_manager' died
23:18:56     INFO -  08-05 06:17:06.688 I/ServiceManager(   33): service 'permission' died
23:18:56     INFO - Return code: 0
23:18:56     INFO - Running command: ['ps', '-C', 'emulator']
23:18:56     INFO - Copy/paste: ps -C emulator
23:18:56     INFO -    PID TTY          TIME CMD
23:18:56    ERROR - Return code: 1
23:18:56     INFO - Running command: ['/builds/slave/test/build/emulator/b2g-distro/out/host/linux-x86/bin/adb', 'devices']
23:18:56     INFO - Copy/paste: /builds/slave/test/build/emulator/b2g-distro/out/host/linux-x86/bin/adb devices
23:18:56     INFO -  List of devices attached
23:18:56     INFO - Return code: 0
23:18:56     INFO - Copying /builds/slave/test/build/emulator-5554.log to /builds/slave/test/build/blobber_upload_dir/emulator-5554.log
23:18:56     INFO - Copying /builds/slave/test/build/qemu.log to /builds/slave/test/build/blobber_upload_dir/qemu.log
23:18:56     INFO - TinderboxPrint: mochitest<br/><em class="testfail">T-FAIL</em>
23:18:56  WARNING - # TBPL WARNING #
So it's running the command ['ps', '-C', 'emulator'] that returns 1? (meaning the emulator is killed before we reach that point)
What do you think we could do about this?
Flags: needinfo?(ahalberstadt)
The ps -C emulator call was added in attempt to figure out whether timeouts we were seeing were caused by the emulator crashing or not. Unfortunately it is broken because by the time we run that command, the automation has cleaned up the emulator one way or another. It is buying us nothing, so we can safely remove it.

However it only gets run if mozharness detects something else wrong (a failure, crash or timeout):
https://hg.mozilla.org/build/mozharness/file/1cbea7b85889/scripts/b2g_emulator_unittest.py#l406

So the real bug here is that something is going wrong and isn't showing up in the tbpl summary (though mozharness is still detecting it).
Flags: needinfo?(ahalberstadt)
Actually, without that return code 1, jobs like this wouldn't even turn orange. So at least it's doing that..
In those logs the tests aren't even being started. The last thing dumped to stdout is:

07:11:47     INFO -  08-12 14:10:39.002 I/Gecko   (  736): ###!!! [Child][MessageChannel::SendAndWait] Error: Channel error: cannot send/recv
07:11:47     INFO -  08-12 14:10:39.002 I/Gecko   (  736):
07:11:47     INFO -  08-12 14:10:39.002 I/Gecko   (  736): [Child 736] WARNING: content process _exit()ing: file ../../../gecko/dom/ipc/ContentChild.cpp, line 1486
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.