cant open app without restarting on foxconn infocus tablet 10" firefox flatfish



Firefox OS
4 years ago
4 years ago


(Reporter: Haider Sajjad, Unassigned)


Firefox Tracking Flags

(Not tracked)


(Whiteboard: [flatfish])


(1 attachment)



4 years ago
Created attachment 8467738 [details]
this is what i see after opening the application downloaded from market place without restarting the device

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

i downloaded app on inFocus F1 tablet 10" and every time i download an app on the device, i cant run it without restarting the device

Actual results:

every time i opened the new downloaded app from market place, it opens the file manager containing the files of that app instead of running that app.
the app works fine after restarting the device.

Expected results:

it should have run the app directly after downloading without showing the files of the app and without requiring the device restart.
i have attached the pictures of the app , after downloading it and then i opened the app without restarting the device


4 years ago
Summary: cant open app without restarting → cant open app without restarting on foxconn infocus tablet 10" firefox flatfish
Could you provide device information such as gaia/gecko version, also the app failed to open after download from marketplace. I have tried on my tablet and it works fine.

Comment 2

4 years ago
i am not sure about gaia or gecko version but every app i download from market place does this! 
eg, apps like mozilla products, cut rope, facebook, soundcloud etc
You can go to Settings > Device Information > More Information to check which version you are on.
And I have tried to download apps from marketplace but things you mentioned doesn't happen.

Device information: 
Gaia      0a2c504ae8c6d37e21d04a3b832aba4928f3028d
Gecko     46c9b0371c8c4591e0e8bd5e889a8555e5e1e4ce
BuildID   20140731110216
Version   34.0a1 Jul 25 01:46:09 CST 2014

Comment 4

4 years ago
that is why i have attached a screen shot with the bug report to justify. i am testing a Mozilla tab 10" from mozilla tab contribution program

my OS version :
firmware revision : flatfish_2014120-1529
platform version: 29.0a1
git commit info : 2014-01-20 07:27:55   62f5852a
I'm doing the same thing as you, working on the tablet.
If you are still using v1.4 that means you are behind main stream, tablet contribution program suggests contributors go with master branch, which is v2.1 now.
In case you have any questions on how to flash your tablet, here's a link to wiki.


Comment 6

4 years ago
thank you for the update! i have updated my tab now. actaully i have recieved the tab last week and it had the previous version as default so i didnt know
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Whiteboard: [flatfish]
You need to log in before you can comment on or make changes to this bug.