If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

hg serve hanging on read()

RESOLVED WORKSFORME

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: fubar, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/719] )

(Reporter)

Description

3 years ago
:ryanvm reported in #releng this morning that his try push was stuck on "searching for changes" yet the push had gone through and builds started on it. 

/var/log/messages showed successful mirror pulls from all web heads. on hgssh1, all that was left was the hg serve process:

  |   |-sshd,24851
  |   |   `-sshd,24859
  |   |       `-hg,24861 /usr/bin/hg -R /repo/hg/mozilla/try serve --stdio

incidentally, there are several other pushes in a similar state, including another try:

  |   |-sshd,8332
  |   |   `-sshd,8337
  |   |       `-hg,8338 /usr/bin/hg -R /repo/hg/mozilla/try serve --stdio
  |   |-sshd,19023
  |   |   `-sshd,19032
  |   |       `-hg,19033 /usr/bin/hg -R /repo/hg/mozilla/releases/l10n/mozilla-beta/vi serve --stdio
  |   |-sshd,25457
  |   |   `-sshd,25464
  |   |       `-hg,25466 /usr/bin/hg -R /repo/hg/mozilla/users/sbruno_mozilla.com/mozilla-central serve --stdio
  |   `-sshd,25469
  |       `-sshd,25477
  |           `-hg,25478 /usr/bin/hg -R /repo/hg/mozilla/users/sbruno_mozilla.com/mozilla-central serve --stdio

They're all stuck on read(0, ...), which is an sshd->hg pipe, e.g.:

sshd      25477    vcs-sync@mozilla.com    9w     FIFO                0,8       0t0 2532268165 pipe
hg        25478    vcs-sync@mozilla.com    0r     FIFO                0,8       0t0 2532268165 pipe

Updated

3 years ago
Blocks: 1017724
(Reporter)

Updated

3 years ago
Component: WebOps: Source Control → Mercurial: hg.mozilla.org
Product: Infrastructure & Operations → Developer Services

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/189]

Updated

3 years ago
Whiteboard: [kanban:engops:https://kanbanize.com/ctrl_board/6/189] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/719] [kanban:engops:https://kanbanize.com/ctrl_board/6/189]
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/719] [kanban:engops:https://kanbanize.com/ctrl_board/6/189] → [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/719]

Comment 1

2 years ago
If this is still an issue, it will get fixed by the new replication system.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.