Closed Bug 1048926 Opened 5 years ago Closed 4 years ago

Fix and re-enable 789075-1.html and 795892-1.html on Android and B2G

Categories

(Core :: Audio/Video, defect)

ARM
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: RyanVM, Assigned: bechen)

References

Details

Attachments

(1 file, 1 obsolete file)

These two tests are currently disabled on Android and B2G, but without a bug on file for fixing them. I've confirmed that they still fail on Try.

https://tbpl.mozilla.org/php/getParsedLog.php?id=45250642&tree=Try

b2g_emulator_vm try opt test crashtest-1 on 2014-08-05 07:20:23 PDT for push eea5f68fe26c
slave: tst-linux64-spot-220

07:42:35     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html
07:42:35     INFO -  REFTEST TEST-LOAD | http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html | 244 / 912 (26%)
07:42:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html | load failed: timed out waiting for reftest-wait to be removed
07:42:35     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
07:42:35     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
07:42:35     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:42:35     INFO -  REFTEST INFO | Loading a blank page
07:42:35     INFO -  REFTEST TEST-END | http://10.0.2.2:8888/tests/content/media/test/crashtests/789075-1.html
07:42:35     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html
07:42:35     INFO -  REFTEST TEST-LOAD | http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html | 245 / 912 (26%)
07:42:35     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html | load failed: timed out waiting for reftest-wait to be removed
07:42:35     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html
07:42:35     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
07:42:40     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 1000
07:42:40     INFO -  REFTEST INFO | Saved log: Updating canvas for invalidation
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
07:42:40     INFO -  REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
07:42:40     INFO -  REFTEST INFO | Loading a blank page
07:42:40     INFO -  REFTEST TEST-END | http://10.0.2.2:8888/tests/content/media/test/crashtests/795892-1.html
Still permafail.

https://treeherder.mozilla.org/logviewer.html#?job_id=10031672&repo=try

09:43:20 INFO - REFTEST TEST-START | http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html
09:43:20 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html | 370 / 1433 (25%)
09:48:22 INFO - REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html | load failed: timed out waiting for reftest-wait to be removed
09:48:22 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
09:48:22 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 791
09:48:22 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
09:48:22 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
09:48:22 INFO - REFTEST INFO | Loading a blank page
09:48:22 INFO - REFTEST TEST-END | http://10.0.2.2:8854/tests/dom/media/test/crashtests/789075-1.html
09:48:22 INFO - REFTEST TEST-START | http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html
09:48:22 INFO - REFTEST TEST-LOAD | http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html | 371 / 1433 (25%)
09:53:24 INFO - REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html | load failed: timed out waiting for reftest-wait to be removed
09:53:24 INFO - REFTEST INFO | Saved log: START http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering WaitForTestEnd
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] WaitForTestEnd: Adding listeners
09:53:24 INFO - REFTEST INFO | Saved log: Initializing canvas snapshot
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_TO_FIRE_INVALIDATE_EVENT
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: dispatching MozReftestInvalidate
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] AfterPaintListener in http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] SendUpdateCanvasForEvent with 1 rects
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] Rect: 0 0 800 791
09:53:24 INFO - REFTEST INFO | Saved log: Updating canvas for invalidation
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: STATE_WAITING_FOR_REFTEST_WAIT_REMOVAL
09:53:24 INFO - REFTEST INFO | Saved log: [CONTENT] MakeProgress: waiting for reftest-wait to be removed
09:53:24 INFO - REFTEST INFO | Loading a blank page
09:53:24 INFO - REFTEST TEST-END | http://10.0.2.2:8854/tests/dom/media/test/crashtests/795892-1.html
I'm going to reproduce them on b2g emulator.
Assignee: nobody → bechen
Since the 795892-1.html doesn't assign the preload action, the preload action will be PRELOAD_NONE(see b2g.js) => no metadataloaded => timeout
Comment on attachment 8642919 [details] [diff] [review]
bug-1048926.patch

Review of attachment 8642919 [details] [diff] [review]:
-----------------------------------------------------------------

Specify preload=metadata since preload=auto could mean different things on different platforms.
Attachment #8642919 - Flags: review?(jwwang) → review+
r=jwwang
address comment 5.
try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4dbe2d87e19b
Attachment #8642919 - Attachment is obsolete: true
Attachment #8643464 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/d44ecfd93252
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.