Long-pressing Back from within overflow should access Back history

RESOLVED DUPLICATE of bug 952290

Status

()

RESOLVED DUPLICATE of bug 952290
4 years ago
2 years ago

People

(Reporter: pwd.mozilla, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140804061222

Steps to reproduce:

In the cases of phones that bind multi-window to the back button, the back within the overfflow menu should provide access to the back history.
(Reporter)

Updated

4 years ago
OS: Linux → Android
Hardware: x86 → ARM
I see on my SGS5 that holding the device back button will both open the multi-window app sidebar and open a prompt for back history.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

4 years ago
I would say it makes sense to open the history on both, the backward and forward button.

I have tested the problem on my LG G3 (it also has only software buttons).
On my device the history pop-up doesn't show up at all. So currently this feature is not reachable for me.

I tested it with multi window enabled and with multi-window disabled (if disabled, the multi window screen does not show up on long-pressing the back button). In both cases it doesn't show up.
(Reporter)

Updated

4 years ago
Blocks: 454880
See Also: → bug 1048969
(Reporter)

Comment 3

4 years ago
Can we get some input from UX?
Need to locate one of these devices first but if I'm understanding this correctly, we're talking about long pressing the hardware back button here right? That should bring up the menu in bug 847435, rather than the platform conventions?

I'm going to have to give this more thought because sometimes taking over these actions are a bit intrusive as they're conventions that the user probably got used to.

(In reply to Alexander Ploner from comment #2)
> I would say it makes sense to open the history on both, the backward and
> forward button.
> 
> I have tested the problem on my LG G3 (it also has only software buttons).
> On my device the history pop-up doesn't show up at all. So currently this
> feature is not reachable for me.

We have bug tracking some of that work for the tablet side that has the back and forward button in a more prominent UI position.
(Reporter)

Comment 5

4 years ago
(In reply to Anthony Lam (:antlam) from comment #4)
> Need to locate one of these devices first but if I'm understanding this
> correctly, we're talking about long pressing the hardware back button here
> right? That should bring up the menu in bug 847435, rather than the platform
> conventions?
No. The LG G3 is the 2014 flagship phone from LG and it has software buttons. However they also have a multi-window/dual window feature. Disabling this feature doesn't allow Fennec to turn on the history back stack and so the idea is that we should enable access to the functionality via the back/forward buttons in the overflow menu.

> I'm going to have to give this more thought because sometimes taking over
> these actions are a bit intrusive as they're conventions that the user
> probably got used to.
We're definitely just talking about basically adding a shortcut to the functionality that's already provided. If we could override the hardware preference, that'd be good. I'm not sure if the Samsung Galaxy S5 has the problem too. But either way, that would be Bug 1048969. This is just about the back/forward buttons in the overflow menu.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952290
You need to log in before you can comment on or make changes to this bug.