"Ctrl+ "shortcut key doesn't match with the underline short cut key letters in Composer

VERIFIED INVALID

Status

()

Core
Keyboard: Navigation
P2
normal
VERIFIED INVALID
16 years ago
15 years ago

People

(Reporter: Yuying Long, Unassigned)

Tracking

({helpwanted})

1.0 Branch
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build: 10-15 0.9.4 branch build on windows and linux.

In Composer, in many places, e.g. the menu items (checking spelling, Undo/Redo
...etc) under Edit.  Ctrl+K doesn't work on "Checking Spelling" (Ctrl+S which
"S" has underline around it will work), Ctrl+Z doesn't work for Undo and Ctrl+U
will work for same reason.

Note:
On Macintosh, the command+K will work for spelling check and command+Z will work
for Undo.  Seems they are from macintosh command key but not work for windows
and linux ctrl key.

So, on windows and linux, the ctrl+ key is not match with the underline  letter,
it's very confuse user, I think we should fix it.

Comment 1

16 years ago
probably a dup of some bug on my list; this keybinding is going away
Assignee: syd → brade

Updated

16 years ago
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Keywords: helpwanted
Target Milestone: mozilla1.0.1 → Future

Comment 2

15 years ago
reporter, please resolve this bug as WORKSFORME if you can no
longer reproduce the bug.
(Reporter)

Comment 3

15 years ago
It's still in latest trunk build.

Comment 4

15 years ago
-->
Assignee: brade → composer
OS: other → All
Priority: -- → P2
Hardware: PC → All

Comment 5

15 years ago
Yuying--could you give an update on this bug?  What specific items on which
builds are wrong?  Is only Composer broken in this way or are other applications
also broken?
(Reporter)

Comment 6

15 years ago
It's not only for Composer, but also on Browser too.  Now I kind of understand
why it confused me:

With some short cut items, e.g. View Page source in Browser or Check Spelling in
Composer; there are showing "Page Source   Ctrl+U" (there is an underline
associated with o", and "Check Spelling   Ctrl+K" (underline associated with S".
In fact, on windows and linux, the shortcut actually works with the underline
letter(s); on Mac, there is no underline with any characters, only Mac command
icon showing for shortcut.

So, on Mac, with current design, it looks/works good; but for windows and linux,
seems there are two options offer for short cut, the underline one works but the
Ctrl+<letter> doesn't match with the underline one and doesn't work. 

Comment 7

15 years ago
I'm not the correct person to explain this since it's a Windows-ism.  The
underline is not necessarily the shortcut key with the control-key.  The
underline character is the accesskey or mnemonic key and is used for navigating
all of the menus (ask a Windows-saavy person to demonstrate; I'm a "Mac" person)

-->invalid
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Component: Editor: Composer → Keyboard: Navigation
Resolution: --- → INVALID

Comment 8

15 years ago
We're no different from standard windows programs.

Check notepad.exe for example.
Save _A_s just means you can type "A" while that window is open to select that
option. You can't use Ctrl+A to do it.
Component: Keyboard: Navigation → Editor: Composer
Version: Trunk → 1.0 Branch
(Reporter)

Comment 9

15 years ago
> Check notepad.exe for example.
> Save _A_s just means you can type "A" while that window is open to 
> select that option. You can't use Ctrl+A to do it.

That's right, but there is no "Ctrl+<letter>" showing there; and if there is
something "Ctrl+<letter>" show up there like "S_ave  Ctrl+S", then will works as
that.

But in our app., the "Ctrl+<letter>" offers Mac shortcut in Windows and linux.

Comment 10

15 years ago
What does Edit > Cut show for underline in notepad?
Does Composer show the same underline?
Component: Editor: Composer → Keyboard: Navigation
(Reporter)

Comment 11

15 years ago
Edit -> Cut_ show as "Ctrl+X", and it works with both Ctrl+X and Ctrl+t, this is
the same as in Composer.

My concern is our app. offer some Mac shortcut key which visible in Windows and
linux but don't work, e.g.: View Page Source, Check Spelling ...etc.

Comment 12

15 years ago
Well, my experience, of both Mozilla and Notepad, is
When Edit menu open, press t (not ctrl+t or ctrl+x) to cut
When no menu open, press ctrl+x (not ctrl+t) to cut

Comment 13

15 years ago
Yuying--if there are specific keybindings that are not working, please file
specific bugs for each one.  Note that the underline character has NOTHING to do
with the letter that is on the right side with "Ctrl".  In the original comment
you said that Control-K does not open the spellchecker in Composer (is that
mozilla or netscape build?).  If that is still a problem, please file a NEW bug
with the details.  Also note that there may already be a bug for spellchecking
not working on Linux due to a conflict with emacs keybindings (I forget if there
is one or not).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.