Ctrl+"numbers" shortcut key doesn't work when menus are displayed

VERIFIED INVALID

Status

()

VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: amyy, Assigned: aaronlev)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build: 10-15 0.9.4 branch build

Steps:
1. Launch browser, go menu Tasks.
2. Windows and Linux:
   You will find there are a few shortcut keys Ctrl+1, 2, 3... under this menu,
which the underline letter is point to "N", "M", "I"...
   So, if you do Ctrl+N will bring up a browser window and Ctrl+M will bring up
a Mail window...etc.   
   However, if you do Ctrl+1, 2, 3... then will do nothing.
3. Macintosh, there is no underline letters appears under tasks menu, but you
get browser or mail window by doing command+1, 2,... 

So, looks like these Ctrl+"numbers" shortcut key are from macintosh
command+"numbers", but not the case for windows and linux Ctrl+"numbers"
shortcut key.

Comment 1

18 years ago
afaik mozilla.org is not maintaining a 0.9.4 branch. should this live in 
bugscape?

beyond that, i just tested 0.9.5 it works there. i can't imagine this was 
broken when 0.9.4 was released.
Whiteboard: BUGSCAPE-FODDER

Comment 2

18 years ago
<w2k 095 talkback>

Comment 3

18 years ago
->keyboard nav
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: doronr → sairuh
(Assignee)

Comment 4

18 years ago
Where is your focus when you type Ctrl+number?

This works for me, as long as I'm not trying to do it while a menu is popped open.
(Reporter)

Comment 5

18 years ago
I was on Tasks:
e.g. if I do Ctrl+A will bring up the Address book, but if I do Ctrl+5, then
there is nothing happens.
(Assignee)

Comment 6

18 years ago
Ylong,

I don't believe the global accelerators listed in menus are even supposed to
work when the menu is open like that.

This is true for most programs. Go to Windows' Wordpad, pull down the edit menu,
and type Ctrl+O. The open dialog doesn't come up.

Try Ctrl+5 when you're not in the menu - when focused in the browser window.

Does it work then?
(Reporter)

Comment 7

18 years ago
In that case, you are right.  I was cofused by the different than Mac.
(Assignee)

Comment 8

18 years ago
-> Expected behavior -- need to be outside of menu
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 9

17 years ago
vrfy invalid
Status: RESOLVED → VERIFIED
OS: other → All
Hardware: Other → PC
Summary: Ctrl+"numbers" shortcut key doesn't work on windows and linux under Tasks menu → Ctrl+"numbers" shortcut key doesn't work when menus are displayed
Whiteboard: BUGSCAPE-FODDER
You need to log in before you can comment on or make changes to this bug.