Restoring closed tab in private browsing retains session token/cookies

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: k61824, Unassigned)

Tracking

31 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140722064054

Steps to reproduce:

1. Open a new private window
2. on that private window, open a new tab
3. on the newly opened tab, login at a website (outlook.com or mail.google.com or bugzilla.mozilla.org)
4. close the tab
5. Press Ctrl+Shift+t to restore the tab


Actual results:

tab is restored with all the session token/cookie intact


Expected results:

If history is not remembered, then either the restore will not be performed or at least the session token and cookie should be destroyed.
(Reporter)

Updated

4 years ago
Component: Untriaged → Private Browsing

Comment 1

4 years ago
I'm fairly sure that just like bug 1048648 (which you also filed), this is essentially a duplicate of bug 490354, and it is by design that you can restore the closed tab, including session cookies, but I'll let Ehsan make a final call here.
Flags: needinfo?(ehsan)

Comment 2

4 years ago
Yes, this doesn't involve storing any of this information on disk, so it's not a privacy issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(ehsan)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.