Closed Bug 1049284 Opened 5 years ago Closed 4 years ago

"Custom Buttons" add-on can't register "custombutton" protocol handler with e10s

Categories

(Firefox :: Extension Compatibility, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
e10s + ---

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: addon-compat)

This is not happen in non-e10s window.

Steps to reproduce:
1. Install https://addons.mozilla.org/en-US/firefox/addon/custom-buttons/ and restart 
2. Attempt to install a button from forum
   e.g., http://custombuttons.sourceforge.net/forum/viewtopic.php?f=4&t=218
         Click a link "Addon List Gen" to  install a button

Actual Results:
The following error page displayed:

The address wasn't understood

Firefox doesn't know how to open this address, because one of the following protocols (custombutton) isn't associated with any program or is not allowed in this context.

Expected Results:
The following alert box should display.

Are you sure you want to install "Addon List Gen" button?

And should be successfully installed when click [OK]
Thanks, Alice0775. This problem with registering the "custombutton" protocol handler sounds similar to bug 940206 or bug 1007978.
tracking-e10s: --- → +
Summary: " Custom Buttons" add-on does not work with e10s → "Custom Buttons" add-on can't register "custombutton" protocol handler with e10s
* Alice0775: can you still reproduce this "Custom Buttons' bug when using the "browser.tabs.remote.autostart" pref instead of the "Open e10s Window" menu? There was a similar bug with Adblock Plus, that we resolved as WORKSFORME after using browser.tabs.remote.autostart. See bug 1007978 comment 14.

* hi Nicholas and SCClockDr, if you have any questions about add-on support for multiprocess Firefox (e10s), just drop by the #e10s IRC channel on irc.mozilla.org. MDN also has a good introduction:

https://developer.mozilla.org/en-US/Add-ons/Working_with_multiprocess_Firefox
Flags: needinfo?(alice0775)
(In reply to Chris Peterson (:cpeterson) from comment #2)
> * Alice0775: can you still reproduce this "Custom Buttons' bug when using
> the "browser.tabs.remote.autostart" pref instead of the "Open e10s Window"
> menu? There was a similar bug with Adblock Plus, that we resolved as
> WORKSFORME after using browser.tabs.remote.autostart. See bug 1007978
> comment 14.

This bug is reported under condition of browser.tabs.remote.autostart = true.

I can still reproduce on latest Nightly.
Flags: needinfo?(alice0775)
This bug is likely related to protocol handler bug 940206.
Depends on: 940206
The developer has been contacted through AMO.
It's still not working. Any fix for bug 940206?
It is still not working on Nightly44.0a1 with e10s.


https://hg.mozilla.org/mozilla-central/rev/26078ba1c7be11cf46706216cad8603b92335cd0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20151024030248
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.