[e10s] Option lists overlaps <select> element when the list expand to the upward direction

VERIFIED FIXED in Firefox 41

Status

()

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: alice0775, Assigned: gw280)

Tracking

(Blocks 2 bugs)

Trunk
mozilla41
x86_64
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10sm7+, firefox40 affected, firefox41 fixed, firefox43 verified)

Details

(Whiteboard: [testday-20150821] )

Attachments

(5 attachments)

Reporter

Description

5 years ago
This maybe happens with Windows Aero/Windows Classic visual style

Steps To Reproduce:
1. Enable e10s
2. Open https://addons.mozilla.org/en-US/firefox/addon/custom-buttons/
3. Scroll to bottom
4. Attempt to change language
   Click Select box of "Other languages"

Actual Results:
  Option list start scroll automatically

Expected Results:
  Should not
Reporter

Updated

5 years ago
See Also: → 1012212
Alice0775, is this select problem different than the e10s browser using Windows' native GUI controls instead of Firefox's own GUI controls? See also bug 978934.
Blocks: fxe10s
tracking-e10s: --- → ?
Flags: needinfo?(alice0775)
Keywords: addon-compat
See Also: → 978934
Reporter

Comment 2

5 years ago
(In reply to Chris Peterson (:cpeterson) from comment #1)
> Alice0775, is this select problem different than the e10s browser using
> Windows' native GUI controls instead of Firefox's own GUI controls? See also
> bug 978934.

I think so,
Current e10s's select dropdown popup has autorepeat button at the top abd bottom of the popup instead of vertical scrollbar.

These autorepeat buttons interfere mouse interaction in this bug.
Flags: needinfo?(alice0775)
Reporter

Comment 3

5 years ago
s/at the top abd bottom/at the top and bottom/
Assignee: nobody → mconley
So this is us not using the right selection widget here. Instead, we use this popup that places the scroll arrow right under the mouse in the scenario that Alice put into comment 0. That causes immediate scroll, and it's not great.

This is very much related to bug 978934.
Attachment #8472611 - Attachment is patch: false
Attachment #8472611 - Attachment mime type: text/plain → image/png
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1053981
Reporter

Comment 6

5 years ago
The problem does not fixed by bug 1053981. 
Re-opened
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Reporter

Updated

5 years ago
Keywords: addon-compat
Reporter

Updated

5 years ago
Whiteboard: [dupe me]
Reporter

Comment 7

5 years ago
The problem is not fixed by bug 1053981.
Are you sure? I can no longer reproduce using the latest Nightly - the auto-scroll arrows are no longer at the top and bottom of the popup dialog. Bug 1053981 should have introduced a scrollbar instead. Can you show me a screenshot of what you're seeing?
Flags: needinfo?(alice0775)
Reporter

Comment 9

5 years ago
Steps To Reproduce:
1. Enable e10s
2  Reduce window height so that expand the option list to the upward direction
3. Open https://addons.mozilla.org/en-US/firefox/addon/custom-buttons/
4. Scroll to bottom
5. Double Click the select Box

Actual Results:
  Option unexpectedly changed and page loaded.
  Because, the option list overlaps with the select box 

Expected Results:
  Should not change value of option
Flags: needinfo?(alice0775)
Reporter

Updated

5 years ago
Summary: [e10s] Difficult to select option → [e10s] Option lists overlappes <select> element when the list expand to the upward direction
Reporter

Updated

5 years ago
Summary: [e10s] Option lists overlappes <select> element when the list expand to the upward direction → [e10s] Option lists overlaps <select> element when the list expand to the upward direction
Reporter

Comment 10

5 years ago
Assignee: mconley → gwright
Reporter

Comment 11

4 years ago
Posted file select_bug.html
Reporter

Updated

4 years ago
Blocks: 1146001

Updated

4 years ago
No longer blocks: 1146001
Duplicate of this bug: 1146001

Comment 14

4 years ago
This bugger is biting me on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0 ID:20150408030205 CSet: 078128c2600a
Version: unspecified → Trunk

Updated

4 years ago
Blocks: e10s-select
We consider this a bit more serious since it can trigger form submits provided your mouse is directly over the popup area vs. the drop down arrow. Moving up to m7.

Updated

4 years ago
Duplicate of this bug: 1156162

Updated

4 years ago
OS: Windows 7 → All
(In reply to Jim Mathies [:jimm] from comment #16)
> *** Bug 1156162 has been marked as a duplicate of this bug. ***

This reproduces in mac as well, there's a good video of this in Bug 1156162.
I don't think it's a dupe, Jim, unless this bug involves:

* Double-press selects on button press, but not on tap
* Opening the previous select when clicking another select elsewhere in the page

Certainly related, though.
Sorry, bad phrasing: not a _direct_ dupe; just don't want a potentially unrelated issue to get dropped by zealous duping.

Comment 20

4 years ago
It looks like we just need 873923 to be able to open a popup at a given rectangle instead of a point as the <select> popup is now.
Depends on: 873923
Nice easy fix, provided the openPopupAtScreenRect patch from bug 873923 lands.
Attachment #8603485 - Flags: review?(enndeakin)

Updated

4 years ago
Attachment #8603485 - Flags: review?(enndeakin) → review+
Duplicate of this bug: 1152807
https://hg.mozilla.org/mozilla-central/rev/1e9c6af2e2ec
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Reporter

Updated

4 years ago
Depends on: 1168247
Duplicate of this bug: 1168709

Updated

4 years ago
Duplicate of this bug: 1173482
Reporter

Updated

4 years ago
Blocks: 1128159
Blocks: 1177445
QA Whiteboard: [good first verify][verify in Nightly only]
I have reproduced this bug with Firefox Nightly 34.0a1 (Build ID: 20140805030300) on 
windows 8.1 pro 64-bit with the instructions from comment 0 .

Verified as fixed with Latest Firefox Nightly 43.0a1(Build ID: 20150822030206)

Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Whiteboard: [testday-20150821]
Reproduced this bug with Nightly 34.0a1 (2014-08-05) by following comment 0 on Linux x64

This Bug is now verified as fixed on Latest Firefox Nightly 43.0a1 (2015-08-26)

Build ID: 20150826030211
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0

As it is also verified on Windows (Comment 27), Marking it as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [good first verify][verify in Nightly only] → [good first verify][verify in Nightly only][bugday-20150826]
You need to log in before you can comment on or make changes to this bug.