[1.4] TypeError: pendingOutgoingCall is null {file: "resource://gre/modules/ril_worker.js" line:3913}

RESOLVED FIXED in Firefox OS v1.4

Status

Firefox OS
RIL
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aknow, Assigned: aknow)

Tracking

unspecified
2.1 S2 (15aug)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 unaffected, b2g-v2.1 unaffected)

Details

Attachments

(1 attachment, 3 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

3 years ago
Created attachment 8468216 [details] [diff] [review]
fix pendingOutgoingCall=null

Comment 2

3 years ago
Comment on attachment 8468216 [details] [diff] [review]
fix pendingOutgoingCall=null

Review of attachment 8468216 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/system/gonk/ril_worker.js
@@ +3909,5 @@
>        } else {
>          if (newCall.state === CALL_STATE_DIALING ||
>              newCall.state === CALL_STATE_ALERTING) {
> +          if (pendingOutgoingCall) {
> +            newCall.isEmergency = pendingOutgoingCall.isEmergency;

Will it be possible that modem set up an ECC call via STK?
if so, should we set newCall.isEmergency to a correct value?
(Assignee)

Comment 3

3 years ago
(In reply to shawn ku [:sku] from comment #2)
> Comment on attachment 8468216 [details] [diff] [review]
> fix pendingOutgoingCall=null
> 
> Review of attachment 8468216 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: dom/system/gonk/ril_worker.js
> @@ +3909,5 @@
> >        } else {
> >          if (newCall.state === CALL_STATE_DIALING ||
> >              newCall.state === CALL_STATE_ALERTING) {
> > +          if (pendingOutgoingCall) {
> > +            newCall.isEmergency = pendingOutgoingCall.isEmergency;
> 
> Will it be possible that modem set up an ECC call via STK?
> if so, should we set newCall.isEmergency to a correct value?

3GPP TS 11.14
"""
It is possible for the SIM to request the ME to set up an emergency call by supplying the number "112" as called party number. If the SIM supplies a number stored in EFECC, this shall not result in an emergency call.
"""

It seems that only "112" is considered as an emergency call. We can do this check.
(Assignee)

Comment 4

3 years ago
Created attachment 8468274 [details] [diff] [review]
#2 Fix pendingOutgoingCall=null
Attachment #8468216 - Attachment is obsolete: true
Attachment #8468274 - Flags: review?(htsai)

Comment 5

3 years ago
(In reply to Szu-Yu Chen [:aknow] from comment #3)
> (In reply to shawn ku [:sku] from comment #2)
> > Comment on attachment 8468216 [details] [diff] [review]
> > fix pendingOutgoingCall=null
> > 
> > Review of attachment 8468216 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > ::: dom/system/gonk/ril_worker.js
> > @@ +3909,5 @@
> > >        } else {
> > >          if (newCall.state === CALL_STATE_DIALING ||
> > >              newCall.state === CALL_STATE_ALERTING) {
> > > +          if (pendingOutgoingCall) {
> > > +            newCall.isEmergency = pendingOutgoingCall.isEmergency;
> > 
> > Will it be possible that modem set up an ECC call via STK?
> > if so, should we set newCall.isEmergency to a correct value?
> 
> 3GPP TS 11.14
> """
> It is possible for the SIM to request the ME to set up an emergency call by
> supplying the number "112" as called party number. If the SIM supplies a
> number stored in EFECC, this shall not result in an emergency call.
> """
> 
> It seems that only "112" is considered as an emergency call. We can do this
> check.

Most of cases, EF_ECC is empty. That's why ro.ril.ecclist/ril.ecclist is introduced.
I would suggest we check ro.ril.ecclist/ril.ecclist to complete the whole set.
Comment on attachment 8468274 [details] [diff] [review]
#2 Fix pendingOutgoingCall=null

Review of attachment 8468274 [details] [diff] [review]:
-----------------------------------------------------------------

Hey Aknow,

Shawn's comment 5 makes sense to me. Please address that, thank you!
Attachment #8468274 - Flags: review?(htsai)
(Assignee)

Comment 7

3 years ago
Created attachment 8468307 [details] [diff] [review]
#3 Fix pendingOutgoingCall=null
Attachment #8468274 - Attachment is obsolete: true
Attachment #8468307 - Flags: review?(htsai)
Comment on attachment 8468307 [details] [diff] [review]
#3 Fix pendingOutgoingCall=null

Review of attachment 8468307 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/system/gonk/ril_worker.js
@@ +3913,5 @@
> +          if (pendingOutgoingCall) {
> +            newCall.isEmergency = pendingOutgoingCall.isEmergency;
> +          } else {
> +            // Don't set |isEmergency|
> +            // The correct value will be set in TelephonyService

Please remove the empty else clause but keep the comment. Thanks!
Attachment #8468307 - Flags: review?(htsai) → review+

Comment 9

3 years ago
[Blocking Requested - why for this release]: No call UI for STK call setup due to this exception. Dolphin/tarako is impacted.
blocking-b2g: --- → 1.4?
As per comment 9, regression, high impact.
blocking-b2g: 1.4? → 1.4+
(Assignee)

Comment 11

3 years ago
Created attachment 8472139 [details] [diff] [review]
(1.4) [final] Fix pendingOutgoingCall=null. r=hsinyi
Attachment #8472139 - Flags: review+
(Assignee)

Updated

3 years ago
Attachment #8468307 - Attachment is obsolete: true
(Assignee)

Comment 12

3 years ago
check-in needed, only for 1.4
https://tbpl.mozilla.org/?tree=Try&rev=ea10978cd991
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/892e68b8ae62
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v1.4: --- → fixed
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S2 (15aug)
You need to log in before you can comment on or make changes to this bug.