Closed Bug 1049334 Opened 7 years ago Closed 7 years ago

loading image cause double GET requests due to favicon loading

Categories

(Firefox :: Tabbed Browser, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 583351

People

(Reporter: ran, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

1. Insert URL of image resource to Firefox. For example: myexample.com/myimage.jpg. 
2. Activate Fiddler\WireShark or observe the server log to see the GET requests.



Actual results:

Firefox make two GET requests to the same image. one for the image itself and one for the favicon.



Expected results:

Only one GET request is being issued.
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Component: Networking: HTTP → Tabbed Browser
Product: Core → Firefox
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583351
You need to log in before you can comment on or make changes to this bug.