Closed Bug 1049370 Opened 7 years ago Closed 7 years ago

WebIDE: wrong accesskey for "Open App…" (projectMenu_selectApp_label)

Categories

(DevTools Graveyard :: WebIDE, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 34

People

(Reporter: flod, Assigned: jryans)

References

Details

Attachments

(1 file)

Noticed while translating after bug 1011464 landed.

webide.dtd

<!ENTITY projectMenu_selectApp_label "Open App…">
<!ENTITY projectMenu_selectApp_accessley "S">

The second string has a typo in the name (accessLey), and is using a letter not available in the label. I didn't check with an en-US build, but "O" should be available.

Code reference is right though
http://mxr.mozilla.org/mozilla-central/source/browser/devtools/webide/content/webide.xul#62

webide.properties

addons_simulator_label=Firefox OS %1$S Simulator (%2$S)

Since we're touching l10n files, can we add a comment here explaining what there variables are?
Try: https://tbpl.mozilla.org/?tree=Try&rev=6dceae3dcdc7
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8475271 - Flags: review?(paul)
Attachment #8475271 - Flags: review?(paul) → review+
https://hg.mozilla.org/mozilla-central/rev/a7c77bdfd4ac
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
I couldn't find old buidls to reproduce the issue, but I check that latest Aurora 34.0a2 2014-10-09 de/it/fr builds has the shortcut Cmd/Ctrl +O in place (all platforms). Marking as verified based on this.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.