Closed Bug 1049450 Opened 5 years ago Closed 5 years ago

Zoom in/out of bing maps is choppy

Categories

(Core :: Layout, defect)

33 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla34
Tracking Status
firefox32 --- unaffected
firefox33 + verified
firefox34 + verified

People

(Reporter: alice0775, Assigned: mattwoodrow)

References

()

Details

(Keywords: perf, regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

Steps To Reproduce:
1. Open http://www.bing.com/maps/
2. Click [-] icon in the map continuously(approx 0.5-1sec interval) until minimum zoom
3. Click [+] icon in the map continuously(approx 0.5-1sec interval) until maximum zoom

(The interval may depend on CPU/Network speed(CPU@2.5GHz/8MADSL))

Actual Results:
choppy

Expected Results:
Smooth

Regression window(m-c)
Good:
https://hg.mozilla.org/mozilla-central/rev/31c5d0a5115d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140715053734
Bad:
https://hg.mozilla.org/mozilla-central/rev/d2d56f9066bf
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140715055935
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=31c5d0a5115d&tochange=d2d56f9066bf


Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a60905d4dfd8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140714163736
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1aa504e62034
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 ID:20140714180536
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a60905d4dfd8&tochange=1aa504e62034


Triggered by:
1aa504e62034	Matt Woodrow — Bug 1034247 - Avoid propogating scale factors down to ThebesLayers if it would result in them being larger than the max texture size. r=roc
Matt, can you help here? Thanks
Flags: needinfo?(matt.woodrow)
Performance regression on a major website. Tracking!
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Removing this meant that we started pre-rendering the transition effects on bing maps. It still wasn't over the texture size limit, so we go ahead with it and render enormous textures, which is slow.

Reverting this seems the safest things to do for now (and doesn't invalidate the original crash fix).

We still need to figure out better prerender/scale propagation heuristics, but this bug isn't the right place.
Attachment #8470579 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/dcffdf59b824
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
Matt, can we have an uplift request for 33 (aurora)? Thanks
Flags: needinfo?(matt.woodrow)
Comment on attachment 8470579 [details] [diff] [review]
Revert the pre-render conditions

Approval Request Comment
[Feature/regressing bug #]: Bug 1034247
[User impact if declined]: Poor performance on bing maps
[Describe test coverage new/current, TBPL]: Tested manually.
[Risks and why]: Super low risk, just reverting to previous behaviour.
[String/UUID change made/needed]: None
Attachment #8470579 - Flags: approval-mozilla-aurora?
Flags: needinfo?(matt.woodrow)
Attachment #8470579 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1046528
Flags: qe-verify+
Duplicate of this bug: 1037230
Reproduced the issue on old Nightly (2014-08-06), verified that the issue is fixed (zooming in bing maps is smooth) on Windows 7 64bit using latest Aurora and Firefox 33 beta 2.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1044571
You need to log in before you can comment on or make changes to this bug.