Visible slowdown in autofilling url domains with unified complete enabled

RESOLVED DUPLICATE of bug 1050683

Status

()

Toolkit
Places
RESOLVED DUPLICATE of bug 1050683
3 years ago
3 years ago

People

(Reporter: Optimizer, Unassigned)

Tracking

unspecified
x86_64
Windows 7
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
1. Have a somewhat filled up profile with lots of history
2. Have unified enabled (browser.urlbar.unifiedcomplete) true (by default in latest nightly)
3. Have browser.urlbar.autoFill as true
4. try to type initial characters of your favorite website (say "fa")
5. Since you are very eager to visit your favorite website, you rapidly type "fa<ENTER>" but instead of "facebook.com" you will be taken to google search (or your default search) page searching for "fa"

This is because there is a very noticeable (> 100ms) lag b/w your typing "fa" and the result "facebook.com" to be auto filled.


Disable unified complete and the problem is fixed. "facebook.com" auto fills withing instant, like <10ms and step 5 is impossible to reproduce
This should be part of the next iteration, at least.
Flags: firefox-backlog+
Added to spreadsheet under 'GMC Scratch Pad' for consideration in next iteration.

(In reply to Marco Bonardo [:mak] (Away 15-31 Aug) from comment #1)
> This should be part of the next iteration, at least.
One of the things I figured off-hand is that we lack Ci.nsIAutoCompleteSearchDescriptor in QueryInterface, so we are not using SEARCH_TYPE_IMMEDIATE :(

another thing is that we have a couple yield before collecting autoFill results, since they are resolved on the next tick we might gain something by collecting autoFill immediately, though we should still order results properly, and that might again lose all of the wins.

I think we should immediately fix the QI (will file a bug apart).
Before touching order of queries we should have Blair's patch in (bug 951624), that would allow to start optimizing the full code rather than putting into some optimization that we might have to drop immediately.
Depends on: 1050683
bug 1050683 just landed in fx-team, and might have an interesting effect on this.
Once it will make a Nightly could you please let me know if it helped?
An alternative experiment you might do immediately without waiting for that, is to set browser.urlbar.delay to 0 and tell me if that solves the issue (bug 1050683 is a better way to do something similar). Rememeber to reset the pref once tested.
Flags: needinfo?(scrapmachines)
(Reporter)

Comment 6

3 years ago
(In reply to Marco Bonardo [:mak] (Away 15-31 Aug) from comment #5)
> An alternative experiment you might do immediately without waiting for that,
> is to set browser.urlbar.delay to 0 and tell me if that solves the issue
> (bug 1050683 is a better way to do something similar). Rememeber to reset
> the pref once tested.

Yes, it does make the auto filling instant
(Reporter)

Updated

3 years ago
Flags: needinfo?(scrapmachines)
I think this is fixed by bug 1050683. please reopen if there's any unexpected slowdown after that.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050683

Updated

3 years ago
Flags: firefox-backlog+ → firefox-backlog-
You need to log in before you can comment on or make changes to this bug.