All users were logged out of Bugzilla on October 13th, 2018

Should have a Finnish keyboard layout

RESOLVED DUPLICATE of bug 1050574

Status

RESOLVED DUPLICATE of bug 1050574
4 years ago
4 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
1) Use Flame
2) Use nightly Gecko+Gaia
3) Try to locate a Finnish keyboard layout in Settings

Actual results:
There's no Finnish layout.

Expected layout:
Expected there to be a Finnish keyboard layout that has the letters ä and ö as top-level keys (i.e. without having to tap-and-hold a and o). The letter Ö should be to the right of the letter L and the letter Ä should be to the right of Ö.

Additional info:
A Finnish hardware keyboard is the same as the Swedish hardware keyboard as has an Å key to the right of P. A Swedish software keyboard should obviously do the same. Also, the Android software keyboard for Finnish has Å to the right of P. However, on a software keyboard for Finnish where Å is available anyway by tapping-and-holding the A key (as is the case with Gaia Keyboard), the real estate traditionally reserved for Å would be more useful to allocate to punctuation that actually occurs more often than Å (which does not occur in Finnish words and is only useful for writing the Swedish language or Swedish names in the context of the Finnish language). (It makes sense to add a key to the right of P to make the first and second row of keys have the same length and to make the virtual key columns line up as on Android and unlike on traditional hardware keyboards.)
(Reporter)

Comment 1

4 years ago
It turns out that the Gaia repo already has sv.js for a Swedish layout. However, it is not available from the UI. :-(
Yes, we need to find a way to ship it w/o impacting disk space.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050574
You need to log in before you can comment on or make changes to this bug.