Mozilla crashes when launched from a locked volume [@ nsComponentManagerImpl::FreeServices]




17 years ago
15 years ago


(Reporter: J.J. Enser, Assigned: Robert John Churchill)



Mac OS X

Firefox Tracking Flags

(Not tracked)


(crash signature)


(1 attachment, 1 obsolete attachment)



17 years ago
Mozilla for MacOS X gets now packaged and distributed as a disk image.
Consequently, the user must copy the Mozilla folder from that disk image to
his/her hard disk before running the app or it will crash.

Even though this is an expected action, we should handle properly the case when
the user "misbehaves" and is tempted to run Mozilla directly from the disk
image, and display a clear message like "Mozilla cannot run from a locked
volume. Please copy it first to your hard disk." ...  or something alike, rather
than crashing.
Not sure if this is MacOS X specific, but I suspect it is not.

Comment 1

17 years ago
I think we should add code to nsApprunner.cpp:VerifyInstallation to detect this, 
and other installation problems like:
* missing Essential Files, or Components
* missing .xpt files

Comment 2

17 years ago
-> a developer.
Assignee: asa → sfraser

Comment 3

17 years ago
*** Bug 107781 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Could Mozilla be crashing when running from a locked disk due to bug 101468?  

Comment 5

16 years ago
Target Milestone: --- → mozilla0.9.9

Comment 6

16 years ago
Created attachment 69399 [details] [diff] [review]
Fix crash on shutdown if startup was aborted

Comment 7

16 years ago
Can I get r from dp, and sr from shaver please?

Comment 8

16 years ago
Created attachment 69401 [details] [diff] [review]
Better patch
Attachment #69399 - Attachment is obsolete: true
Comment on attachment 69401 [details] [diff] [review]
Better patch

I guess that's OK.  I'd be happier with the cnt declaration inside the if block
for the gComponentManager test, I think.

Seems like there's a deeper bug here, though: XPCOM should never be returning
from NS_InitXPCOM in a half-initialized state, and we should be checking right
at the top of NS_ShutdownXPCOM if we've been initialized.

In the meantime, though, crashing sucks.  (I'm getting pretty soft in my old
Attachment #69401 - Flags: superreview+

Comment 10

16 years ago
I'll do:

    // Finally, release the component manager last because it unloads the
    // libraries:
    if (nsComponentManagerImpl::gComponentManager) {
      nsrefcnt cnt;
      NS_RELEASE2(nsComponentManagerImpl::gComponentManager, cnt);
      NS_WARN_IF_FALSE(cnt == 0, "Component Manager being held past XPCOM 

Comment 11

16 years ago
Comment on attachment 69401 [details] [diff] [review]
Better patch

Attachment #69401 - Flags: review+

Comment 12

16 years ago
Spun off bug 125415 for the user notification issue.

Comment 13

16 years ago
Checked in.
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
*** Bug 101468 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 146644 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Reopening due to new report of this problem (marked duplicate of this bug).
Resolution: FIXED → ---

Comment 17

16 years ago
A quick look at this seems to implicate the nsComponentManagerImpl call to
FreeServices(). Based on the offsets and register values, it would appear that
gComponentManager is NULL.

I was able to reproduce this in both the trunk and branch packaged builds, but
was unable to reproduce it with a debug build copied to a locked volume.


16 years ago
Severity: normal → critical
Keywords: crash

Comment 18

16 years ago
robert, can you take a look at this crasher?
Assignee: sfraser → rjc

Comment 19

16 years ago

Comment 20

16 years ago
FYI: The bug still exists in 1.0 (final), but you probably knew that already :-)

Comment 21

16 years ago
Could this bug be moved to XP Apps or XP Miscellany instead of Browser-General?
Summary: Mozilla crashes when launched from a locked volume → Mozilla crashes when launched from a locked volume [@ nsComponentManagerImpl::FreeServices]


16 years ago
Component: Browser-General → XPCOM
QA Contact: doron → scc

Comment 22

16 years ago
*** Bug 142055 has been marked as a duplicate of this bug. ***
Not possible to install Mozilla on a network shared protected volume ?

Comment 24

16 years ago
Jean-Pierre's comment is pretty short, but I guess that he tried to install on
an NFS partition and it failed because it lost some AFP resource fork junk.
I know this has happened to me.
I have nerver tried, but in a network the application are generally installed on
mounted protected partitions to avoid local installations. For a mac: an Apple
Share volume, so there is  not a Resource fork problem. Because this volume is
generaly protected, the same problem can occur. (If it is really a protection
I am on Mac os 9.1 and installed a new version yesterday.
A look in My mozilla folder show that the following files have been  modified
since the installation:
- search Plugins-> google (it is my default search)
- Component -> xpti.dat

Why theese files have the mofications dates changed ? Probably an uncessary open
with write permission. Theese dates does not correspond to a launch.
The only think that can cause problems is the auto-update options in the prefs.
I don't know if it works yet.

I have done another try (On Mac OS9).
I have created a protected .img file, copied mozilla folder into it.

Now i am writing, using this copy, all works fine for the moment. It seems a
MacOS X problem.

Comment 26

16 years ago
*** Bug 179159 has been marked as a duplicate of this bug. ***
Target Milestone: mozilla0.9.9 → ---

Comment 27

15 years ago
Running OS X 2003042208 from its initial disk image seems to cause no crashes or
hangs. XPI installs failed due to permissions issues but did not cause crash or
hang either. Are the more complex scenarios still a problem? If so can someone
post steps to create a package/installation setup that fails?

Comment 28

15 years ago
last call for a revised scenario that still crashes before I mark WFM

Comment 29

15 years ago
Well, I just wanted to let you know that for 1.4 and 1.5alpha it works for me. I guess it has been 

Comment 30

15 years ago
I downloaded

Each of these seemed to execute OK from the disk image (.dmg file) which, in each case, is a locked 
volume.  I viewed some basic HTML pages with images while executing from the disk image.  I 
didn't see any problems.

Comment 31

15 years ago
alrighty then... marking WFM... if anyone is still crashing here please provide
step by step instructions...

thx all for retesting
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ nsComponentManagerImpl::FreeServices]
You need to log in before you can comment on or make changes to this bug.