nsParser::Tokenize takes 8% of startup

VERIFIED FIXED in mozilla0.9.8

Status

()

defect
P2
normal
VERIFIED FIXED
18 years ago
5 years ago

People

(Reporter: dp, Assigned: dp)

Tracking

({perf})

Trunk
mozilla0.9.8
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Assignee

Description

18 years ago
nsParser::Tokenize takes 8% of startup

Harish, if you have the time, feel free to take this bug. If not I will work on
this with your help.
Assignee

Updated

18 years ago
Blocks: 7251
Status: NEW → ASSIGNED
Keywords: perf
Target Milestone: --- → mozilla0.9.6

Comment 1

18 years ago
dp, any idea where exactly the time is being spent??
Assignee

Comment 2

18 years ago
I will bring my quantify results we can look at it together.
Assignee

Updated

18 years ago
Depends on: 105137

Comment 3

18 years ago
shouldn't we mark this a dup of bug 105138?
Assignee

Updated

18 years ago
Priority: -- → P2

Comment 4

18 years ago
My old measurements showed the majority of the tokenizing time being spent
allocating things so I would say that this is a dupe of bug 105138.
Assignee

Updated

18 years ago
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Assignee

Comment 5

18 years ago
Will work more on this once Harishd lands bug 105137
Daniel, I think we should reanalyze once harishd fixes
Target Milestone: mozilla0.9.7 → mozilla0.9.8
Assignee

Comment 6

18 years ago
With harish fixing the XML parser good, this one is pretty much done.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Verified fixed as comment #6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.