Youtube html5 video player doesn't work with captions on

RESOLVED WORKSFORME

Status

()

Core
Audio/Video
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: kalviskajaks, Unassigned)

Tracking

34 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140806030201

Steps to reproduce:

1) Open a youtube video with available captions. for example https://www.youtube.com/watch?v=AHKiGl02NmU&feature=youtu.be
2) Tun on the captions.
3) Reload page and try to start the video.


Actual results:

Video doesn't play nor load.


Expected results:

Without captions turned on it plays fine. If captions are turned on AFTER the video has started playing/loading everything works fine too. Safe mode doesn't make any difference.

If flash player is forced instead of the html5 player the video plays fine too.
Confirmed 34.0a1 (2014-08-07), Win 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

4 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

4 years ago
I can reproduce on 32 beta and 34. Can't reproduce on 31 because I don't get an HTML5 player on OS X for this video, not sure why.

I don't really know what the issue could be here; it seems to be it's almost just as likely to be a page issue, but in that case we should probably get in touch with whatever contacts we have at youtube as soon as possible...
Flags: needinfo?(gijskruitbosch+bugs)
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 3

4 years ago
Ralph, AFAICT you might know more about our work on CC and web video, any idea what's going on here?

(I don't see any errors in the console, just CSS stuff, and trying to debug youtube's minified JS didn't get me anywhere, but I might not have tried hard enough...)
Flags: needinfo?(giles)
Probably some event we're not firing. We haven't implemented all of those. I didn't try debugging the minified js though.
Flags: needinfo?(giles)
(Reporter)

Comment 5

4 years ago
Could not reproduce anymore with newest nightly, setting status to resolved.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.