Closed Bug 1049744 Opened 5 years ago Closed 5 years ago

[l10n] WebIDE: menus in the main windows should not truncate longer strings

Categories

(DevTools :: WebIDE, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 34

People

(Reporter: flod, Assigned: jryans)

References

Details

Attachments

(3 files)

Given the amount of space available, we should do better than truncated the translation.

Attached screenshot of the menus on an Italian build.
Try: https://tbpl.mozilla.org/?tree=Try&rev=ee33ebea6796
Assignee: nobody → jryans
Status: NEW → ASSIGNED
Attachment #8477520 - Flags: review?(paul)
If I used with and not min-width in the first place, it's because I was running into issues with panel sizing with min-width (panel's geometry is a bit magic).

Please make sure this works on the 3 platforms, especially when there's a *vertical* overflow.
Tested on Linux. Appears to work as expected. Apparently, I can't reproduce the issues I mentioned in comment 2.
Attachment #8477520 - Flags: review?(paul) → review+
Windows appears to work as it does in the current Nightly build as well.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e04d310ad616
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 34
Flags: qe-verify+
Attached image itTruncatedOpt.png
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

Using latest l10n-it Nightly 20140916133140, I can still see the options truncated if Simulator is started (scroll bar becomes visible). This doesn't happen if WebIDE is opened in full screen.

Is this expected or should I file a follow-up bug?
Flags: needinfo?(jryans)
(In reply to Petruta Rasa [QA] [:petruta] from comment #7)
> Created attachment 8490760 [details]
> itTruncatedOpt.png
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
> 
> Using latest l10n-it Nightly 20140916133140, I can still see the options
> truncated if Simulator is started (scroll bar becomes visible). This doesn't
> happen if WebIDE is opened in full screen.
> 
> Is this expected or should I file a follow-up bug?

Hmm, I see what you mean... it seems the max-width is only applied when there is no vertical scrollbar.

Yes, please file a new bug for this!
Flags: needinfo?(jryans)
Flags: needinfo?(petruta.rasa)
Flags: needinfo?(petruta.rasa)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.