Closed Bug 1049746 Opened 5 years ago Closed 5 years ago

Firefox on linux-arm crashes with SIGSEGV when trying to download files

Categories

(Firefox :: Untriaged, defect, critical)

31 Branch
ARM
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1050258

People

(Reporter: gbh, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux armv7l; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140715215125

Steps to reproduce:

Open Firefox.
Go to any website. 
Try to download a file or save a link.

I built the nightly from source and the same issue exists.

Output of uname -a on my system
Linux localhost 3.8.11 #1 SMP Thu Jul 24 13:49:20 PDT 2014 armv7l armv7l armv7l GNU/Linux



Actual results:

Firefox crashes with Segmentation fault.
Hardware: Other → ARM
Severity: normal → critical
crash report for this bug bp-0c7fffce-c788-4d70-9a58-02ba82140806
(In reply to gbh from comment #1)
> crash report for this bug bp-0c7fffce-c788-4d70-9a58-02ba82140806

This doesn't have symbols. Can you catch the same crash in gdb or another debugger and provide a working stacktrace?
Flags: needinfo?(gbh)
There's some detail to, probably, the same problem on debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756426
How do i capture the crash in gdb ?

Thanks,
Bharath
Flags: needinfo?(gbh)
I built the nightly source with debug symbols enabled.
This is the backtrace i get after the crash when i run it through gdb.

#0  0xb0145b18 in nsCOMPtr<nsIURI>::nsCOMPtr (this=0x96ffa38c, aRawPtr=0xbeff8884) at ../dist/include/nsCOMPtr.h:571
#1  0xb3b1c0d8 in mozilla::places::(anonymous namespace)::SetDownloadAnnotations::SetDownloadAnnotations (this=0x96ffa380, aDestination=0xbeff8884)
    at /home/bharath/tmp/mozilla-central/toolkit/components/places/History.cpp:1441
#2  0xb3b23f28 in mozilla::places::History::AddDownload (this=0xa49570d0, aSource=0xa497af80, aReferrer=0x0, aStartTime=1407350925545000, 
    aDestination=0xbeff8884) at /home/bharath/tmp/mozilla-central/toolkit/components/places/History.cpp:2643
#3  0xb013969c in NS_InvokeByIndex (that=0x96ffa38c, methodIndex=3204417668, paramCount=3204417668, params=0xbeff8960)
    at /home/bharath/tmp/mozilla-central/xpcom/reflect/xptcall/md/unix/xptcinvoke_arm.cpp:407
#4  0x00000000 in ?? ()
For some reason on every crash the aDestination value is 0xbeff8884.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1050258
You need to log in before you can comment on or make changes to this bug.