Let developers specify if their app works offline or not

VERIFIED FIXED in 2014-11-25

Status

P2
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: szdy12, Assigned: mstriemer)

Tracking

2014-11-25
Points:
---

Details

(Whiteboard: [repoman] [userman])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140804164216

Steps to reproduce:

Packaged apps are labelled as "works offline", even if they need an internet connection.


Actual results:

Marketplace assumes that packaged apps will work offline. This assumption is wrong, because packaged apps may need internet connection to "work". Currently, users get confused and complain.


Expected results:

There should be a checkbox (or a field in the app manifest) whether an app requires internet connection.
See Bug 861303

Comment 1

4 years ago
I can confirm this.

Also today I received an email about it from one of my users.

My app "World Radio Player" is wrongly labeled as "Works offline":
https://marketplace.firefox.com/app/world-radio-player/

Yes it is packaged as `application.zip` and it opens fine, but the app cannot play any of the Internet radio stations without an Internet connection.

I would like to have an option to specify this explicitly either via:

1. Firefox Marketplace "Edit Listing" "Technical Details" section for the app.

or

2. In the `manifest.webapp` file.
Yeah, "works offline" is currently just an educated guess. It works for many apps, but not all. The plan was to implement the basic functionality first and then add a way for developers to set that setting themselves, we just never got around to do it - I agree that we should.
Status: UNCONFIRMED → NEW
Component: Consumer Pages → Developer Pages
Ever confirmed: true
Summary: applications should be able to decide explicitly if they "work offline" → Let developers specify if their app works offline or not

Updated

4 years ago
Keywords: productwanted
Priority: -- → P4
Let's have developers declare this on the app details in the technical details and in the submission process.  As cvan suggested in Bug 861301#31 "my app works without an Internet connection."  

We could pre-populate this based on the assumption that packaged apps do work offline.  This is a reasonable assumption for most of the packaged apps today (given lack of any other information) though certainly is not true for many cases.   

A developer should at least be able to override the current setting.
Google's Chrome manifest format allows an `offline_enabled` key:
https://developers.google.com/chrome/apps/docs/developers_guide#offline

That key does not exist in the new W3C Manifest spec (landed in Chrome, coming to Firefox in bug 997779):
https://w3c.github.io/manifest/#manifest-members

But per the new spec, it's totally okay to use proprietary keys:
https://w3c.github.io/manifest/#extensibility

So the Marketplace/MDN could recommend adding `moz_offline_enabled`, and the Marketplace could parse that info., store it, and use that as the heuristic for showing the "Works Offline" message (and when filtering by the PotatoSearch `:offline` keyword).

Comment 6

4 years ago
Lets add a checkbox to the developer hub for flagging as working offline as the first priority.
Keywords: productwanted
Priority: P4 → P2
Whiteboard: [repoman]

Updated

4 years ago
Duplicate of this bug: 1083259

Comment 8

4 years ago
ConnectA2 reached out to us regarding the "works offline" tag. ConnectA2 is shown with the “works offline” tag on the marketplace, they have users that are unhappy because the application needs the Internet to connect while the marketplace states that it “works offline”. 

A fix that lands sooner will be very valuable to avoid more unhappy users for ConnecA2 and other apps that are in similar situations. 

Thanks,
Didem
Whiteboard: [repoman] → [repoman] [userman]
Assignee: nobody → mstriemer
(Assignee)

Comment 9

4 years ago
https://github.com/mozilla/zamboni/pull/2741
Status: NEW → ASSIGNED
(Assignee)

Comment 10

4 years ago
https://github.com/mozilla/zamboni/commit/bf7f64e162b02014ce159316ad0e039085c1aabc
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2014-11-25

Comment 11

4 years ago
Verified as fixed in FF36(Win7) in marketplace-dev.allizom.org
The check box is added in the submission flow and in the edit listing page, the developer can specify if the app works ofline or not.
Postfix screencast: http://screencast.com/t/od5CxucPl  http://screencast.com/t/X7qttPdk  http://screencast.com/t/7U6YIb5TO
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.