If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent B2G leakcheck | 5100 bytes leaked (BluetoothService, Composer2D, CondVar, ExpirationTrackerObserver, LazyIdleThread, ...)

RESOLVED FIXED in Firefox 34, Firefox OS v2.1

Status

()

Core
Graphics: Layers
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: walter)

Tracking

({intermittent-failure, mlk})

unspecified
mozilla34
ARM
Gonk (Firefox OS)
intermittent-failure, mlk
Points:
---

Firefox Tracking Flags

(firefox32 unaffected, firefox33 unaffected, firefox34 fixed, firefox-esr24 unaffected, firefox-esr31 unaffected, b2g-v2.1 fixed)

Details

(Reporter)

Description

3 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=45350226&tree=Mozilla-Inbound

b2g_emulator_vm mozilla-inbound debug test mochitest-debug-7 on 2014-08-06 10:07:47 PDT for push 931943302ba5
slave: tst-linux64-spot-925

11:07:33     INFO -  nsTraceRefcnt::DumpStatistics: 1025 entries
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 BluetoothService (52 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 Composer2D (12 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 5 CondVar (80 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 ExpirationTrackerObserver (16 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 LazyIdleThread (88 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 14 Mutex (168 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 PProcLoaderParent (400 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 PSharedBufferManagerChild (400 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 PSharedBufferManagerParent (400 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 2 PerThreadData (24 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 5 ReentrantMonitor (80 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 2 RefCountedMonitor (64 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 3 RefCountedTask (24 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 6 SocketConsumerBase (120 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 3 WeakReference<MessageListener> (24 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 3 ipc::MessageChannel (816 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 nsAStreamCopier (80 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 nsPipe (176 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 nsSocketTransport (344 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 1 nsSocketTransportService (152 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 135 nsStringBuffer (1080 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 32 nsTArray_base (128 bytes)
11:07:33     INFO -  TEST-INFO | leakcheck | leaked 3 nsThread (372 bytes)
11:07:33  WARNING -  TEST-UNEXPECTED-FAIL | leakcheck | 5100 bytes leaked (BluetoothService, Composer2D, CondVar, ExpirationTrackerObserver, LazyIdleThread, ...)
This is caused by the ZoomConstraints not appearing, which means we don't get what is effectively a -1 that they add.
Component: Bluetooth → Graphics: Layers
Depends on: 1047755
Product: Firefox OS → Core
Should not be an issue anymore.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Updated

3 years ago
Assignee: nobody → wlitwinczyk
status-b2g-v2.1: --- → fixed
Target Milestone: --- → mozilla34
(Reporter)

Updated

3 years ago
status-firefox32: --- → unaffected
status-firefox33: --- → unaffected
status-firefox34: --- → fixed
status-firefox-esr24: --- → unaffected
status-firefox-esr31: --- → unaffected
You need to log in before you can comment on or make changes to this bug.