about:newtab counter intuitive with search engine without logo

RESOLVED DUPLICATE of bug 1032324

Status

()

RESOLVED DUPLICATE of bug 1032324
4 years ago
4 years ago

People

(Reporter: arnaud.bienner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The search bar integrated in about:newtab is pretty cool :)

However, one thing I noticed that is a bit disturbing IMHO:
- clicking the search engine logo pops up a menu which allows to change the search engine used (like in the search bar field next to the URL bar): that's great.
- BUT, when selecting a search engine which doesn't have a logo, the logo button disappears, as well as the possibility to pop the menu to change the search engine from the about:newtab. Still possible from the search bar field, but this is counter intuitive IMO.

I believe we should have a default logo instead (something like what we have in the search bar field), so the popup menu will always be accessible.

One last thing: I see no reasons to not always have a place holder with the search engine's name, like we have in a search bar field. (i.e. why we have [2] and not always [3]).
IMHO we should be consistent here, and always have a place holder. Or maybe this is not needed on because we suppose the logo will have a readable name? (which is not the case in the search bar field next to the URL bar because the logo are very small).


[1]: http://lxr.mozilla.org/mozilla-central/source/browser/base/content/newtab/search.js#189
[2]: http://lxr.mozilla.org/mozilla-central/source/browser/base/content/newtab/search.js#186
[3]: [1]: http://lxr.mozilla.org/mozilla-central/source/browser/base/content/newtab/search.js#190
(Reporter)

Comment 1

4 years ago
Created attachment 8468669 [details] [diff] [review]
aboutnewtab.patch

I made a small patch to illustrate what I mean (pretty bad mainly because I'm using a data uri directly into the code, but this is really just to demonstrate my point).
(Reporter)

Updated

4 years ago
Depends on: 1028985
(Reporter)

Comment 2

4 years ago
Adding needinfo Drew as I saw you were involved in the design and in the implementation of this feature, so I would like to have your point of view.
Flags: needinfo?(adw)

Comment 3

4 years ago
Thanks for filing, I agree with you.  Bug 1032324 happens to already cover this, so I'm going to mark this as a duplicate.  I'll flag a UX person on that bug to ask for his opinion.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(adw)
Resolution: --- → DUPLICATE
Duplicate of bug: 1032324
You need to log in before you can comment on or make changes to this bug.