XP BSOD (bluescreens) with Google fiber connection

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
--
critical
RESOLVED INCOMPLETE
4 years ago
3 years ago

People

(Reporter: weaver.thomas1, Unassigned)

Tracking

({crash, stackwanted})

31 Branch
x86
Windows XP
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I have XP SP3.  When using a very high speed connection (Google Fiber), Firefox either crashes or XP restarts or dumps memory (blue screen of death).  This has happened many times.  It only happens when using the ultra high speed connection.  It is very easy to reproduce when on news websites that load and pre-load lots of content.

Steps:
1) Use XP and a high speed connection
2) Start visiting news websites that load and pre-load lots of content, such as www.msnbc.com, but I have reproduced it on various news websites.
3) Visit pages until your computer crashes, usually within a few minutes, as you open various pages.


Actual results:

I have noted one of several results repeatedly:
1)  My computer usually will suddenly begin a physical memory dump, giving me the "blue screen of death",
2)  A few times my computer has just restarted, without the "blue screen of death", a friend with XP has also had this occur several times, or
3)  My friends computer will usually just have Firefox crash.

I have been able to reproduce this repeatedly and a friend using a different computer and the same fiber connection has also replicated it.  We have done it at two different localities that have Google Fiber connections.


Expected results:

I should have been able to continue using the browser and my computer.
(Reporter)

Comment 1

4 years ago
I have tried using Firefox in safe mode and the crash/restart/memory dump still occurs.

Comment 2

4 years ago
Any crash report IDs? Specific sites to trigger this? Have you tried using a bandwidth limiting tool and does that actually work? Does this only happen on XP or also on Windows 7 / 8 / Mac / Linux ? Have you checked your computer isn't overheating or anything like that? (which would be a more usual cause for a system reboot without a BSOD, which isn't really something I've ever seen an application do...).
Flags: needinfo?(weaver.thomas1)
(Reporter)

Comment 3

4 years ago
I will try to get some crash report IDs from my friend who has had the crashes.  My computer has always had the memory dump "blue screen of death" or restarted and thus not created a Firefox crash report.

Specific sites have been numerous.  As mentioned above, msnbc.com would be an example.  They have always been major news sites where significant content is being loaded and pre-loaded.  It has happened both when sitting on a page reading (while pre-loading is going on) and when opening links to other news articles in new tabs (thus while new tabs are loading).  I can usually force it to happen within 5 minutes or less just going to such a site and reading any article, opening interesting links to other news articles on the same website in new tabs.

I have not heard of a bandwidth limiting tool, so I will look into that and let you know.  I am guessing that Firefox has a way of loading huge volumes of content into the cache which XP is unable to check properly and thus the system shuts down to avoid critical OS files being overwritten.  That is often what the blue screen of death means as I understand it.  It would seem that it is not a problem with a normal high speed connection, but the largely unlimited bandwidth of a fiber connection creates a significant problem.  Again, I will look into this and let you know.

My computer has not been showing any signs of overheating, that I have noticed, when this happens.  The fan has not been running and I can cause it within moments of booting up while the computer is still cold.  I don't think that is part of the problem.

Comment 4

4 years ago
still lacks stack.
feel free to update the bug report
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(weaver.thomas1)
Keywords: crash, stackwanted
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

4 years ago
I was not able to get a crash report from my friend.  My computer never generated any, because the blue screen of death does not allow such.  I tried to find a bandwidth limiting tool, but was unable to find one compatible with XP & FF30+.  Throttle was highly recommended, but abandoned after FF4.  I found a stackexchange post on the topic (http://superuser.com/questions/330501/how-can-i-simulate-a-slow-connection-or-limit-the-bandwidth-that-firefox-can-us), but links appeared to be outdated and I could not find the recommended limiters using a Google Search.  I have started using IE when I have to use a hotspot with Google Fiber, but generally tried to avoid them, as I much prefer Firefox.

I am happy to try a bandwidth limiting tool if someone can recommend one that works with FF30+ and XP.  I do not like having my system crash, so I am not planning on fiddling around a bunch.  Back when I made the report, I experimented a lot and it is definitely Google Fiber, XP and FF that is causing the crash.  It did not happen with IE or Google Earth or any other program, it only started when I started using Google Fiber connections.  It happened every time I used Google Fiber and FF for many days.  It has not happened even once since I stopped using Google Fiber.  It is clearly a big hole and I am happy to try and hunt it down if you like, but I will need some help.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 6

4 years ago
I'll leave it to :Gijs and others to decide the fate of this, but if the OS BSODs then it's likely an OS level driver that is at fault and not firefox, despite the fact that IE and no other apps *appear* to show the same issue
Summary: Firefox crashes XP with fiber connection → XP BSOD (bluescreens) with Google fiber connection

Updated

3 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 7

3 years ago
Yeah, as it is, it's hard to even suggest what to follow up on, as there are so many different possibilities. Could be an OS issue (what OS does your friend's machine run?), or a driver issue (did you check for updates for any of your hardware drivers, but particular the wifi/networking ones?), or a hardware issue (faulty RAM or CPU or disk or network hardware all sound like options), ...

Could even see if this started happening with a particular Firefox version or not to see if that provides any clues.

If XP was perfect, Firefox in and of itself should never be able to cause a BSOD... it clearly isn't, but it's also no longer getting significant updates.

While I understand that the current situation is frustrating, I don't think there's much Firefox (or its programmers, ie 'we') can do here without much more information that demonstrates a clearer link to Firefox doing something wrong (rather than hardware/XP/driver issues merely triggered by otherwise correct code in Firefox that happens to not be in IE) being the cause of the issue here. Re-resolving as incomplete for this reason.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.