[B2G][Bitcasa] App launches to blank white screen

REOPENED
Unassigned

Status

Tech Evangelism
Preinstalled B2G Apps
REOPENED
4 years ago
4 years ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8468753 [details]
logcat.txt

Description:
When the Bitcasa app is launched it brings the user to a blank white screen.


Repro Steps:
1) Update a Flame to 20140806000200
2) Download "Bitcasa Camera Backup" app
3) Launch app
4) Observe White screen

Actual:
User is brought to a blank white screen

Expected:
It is expected that the user is brought to an information screen.

Environmental Variables:
Device: Flame 2.0 (319mb)
Build ID: 20140806000200
Gaia: 5ba22d458fdb63bd72c59de53c701d0efe35c1e2
Gecko: 6fbc60a80c6d
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Keywords: Fail

Repro frequency: 100%
See attached: video clip(http://youtu.be/io-xuUUJQLc), logcat
(Reporter)

Comment 1

4 years ago
This issue occurs in 2.1 Flame (319mb), 2.1 Buri, 2.0 Flame (512mb), 2.0 Buri.

Environmental Variables:
Device: Flame Master (319mb)
Build ID: 20140806040201
Gaia: 88295e1ec6d52bd63d45ea0e3673a3f933f4a6b9
Gecko: 6cbdd4d523a7
Version: 34.0a1 (Master)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (512mb)
Build ID: 20140806000200
Gaia: 5ba22d458fdb63bd72c59de53c701d0efe35c1e2
Gecko: 6fbc60a80c6d
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Buri Master
Build ID: 20140806073058
Gaia: 5e6ef81cb9e917657ce050f598229dfc83c58b8f
Gecko: bdf301b20cab
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Buri 2.0
Build ID: 20140805183011
Gaia: 5ba22d458fdb63bd72c59de53c701d0efe35c1e2
Gecko: 6fbc60a80c6d
Version: 32.0 (2.0)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
User is brought to a blank white screen

--------------------------------------------------------------------------------------
This issue does not occur on 1.4 Flame (319mb), 1.4 Buri


Environmental Variables:
Device: Flame 1.4 (319mb)
Build ID: 20140806063014
Gaia: e9dce1f60f729e228810f751417681b5ff937b6b
Gecko: 7d4dbbed7aa0
Version: 30.0 (1.4)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Device: Buri 1.4
Build ID: 20140806063014
Gaia: e9dce1f60f729e228810f751417681b5ff937b6b
Gecko: 7d4dbbed7aa0
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Result:
The user is brought to the app information screen
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

Nominating this 2.0? since this is a regression and the app opens to a white screen.
blocking-b2g: --- → 2.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: ckreinbring
NI sid here to get started given the log points to CSP errors and I remember we made changes in 2.0 related to it ?
Flags: needinfo?(sstamm)
CSP thinks the app is using inline scripts. Is it? That is forbidden by CSP. I'm not sure why it wasn't blocked before.
Flags: needinfo?(sstamm)
The CSP bug bhavana mentions (if it is the cause) is bug 858787.
See Also: → bug 858787
(In reply to Sid Stamm [:geekboy or :sstamm] from comment #5)
> The CSP bug bhavana mentions (if it is the cause) is bug 858787.

Note - if this is true, then the window will likely involve m-c builds around June 11th.
The pushlog suggests both b2g-inbound and mozilla-inbound

Regression window
Last working
BuildID: 20140423000005
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko: ac376a4e8174
Platform Version: 31.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First broken
BuildID: 20140423133003
Gaia: 33b5bcb1a092172c983ef178766869aba738ad4d
Gecko: 3cd4615c60ba
Platform Version: 31.0a1
Firmware: v123
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Working Gaia / Broken Gecko = Repro
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko: 3cd4615c60ba
Broken Gaia / Working Gecko = No repro
Gaia: 33b5bcb1a092172c983ef178766869aba738ad4d
Gecko: ac376a4e8174
Gecko push log: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ac376a4e8174&tochange=3cd4615c60ba


B2G-inbound
Last working
BuildID: 20140423060011
Gaia: 0670141b70e71238a89dacf56ada0fcf8ff7106f
Gecko: a2dcf639dee1
Platform Version: 31.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

First broken
BuildID: 20140423120009
Gaia: bbc76bcdc937bdbaf3935351ba2d532449c63bf8
Gecko: d1cabfe507ef
Platform Version: 31.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = Repro
Gaia: 0670141b70e71238a89dacf56ada0fcf8ff7106f
Gecko: d1cabfe507ef
Broken Gaia / Working Gecko = No repro
Gaia: bbc76bcdc937bdbaf3935351ba2d532449c63bf8
Gecko: a2dcf639dee1
Gaia pushlog: http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=a2dcf639dee1&tochange=d1cabfe507ef


Mozilla-inbound
Last working
BuildID: 20140422120008
Gaia: f0463704888881b8ed1619e8d4b0d851b0e0311b
Gecko: 418c50532eea
Platform Version: 31.0a1 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

First broken
BuildID: 20140423000006
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko: b747c35ac54b
Platform Version: 31.0a1
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Working Gaia / Broken Gecko = Repro
Gaia: f0463704888881b8ed1619e8d4b0d851b0e0311b
Gecko: b747c35ac54b
Broken Gaia / Working Gecko = No Repro
Gaia: d8904c5af6152f5d647a93a0c31227171ddecd87
Gecko: 418c50532eea
Gecko push log: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=418c50532eea&tochange=b747c35ac54b
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
(Reporter)

Comment 8

4 years ago
The Marketplace URL for the app is:
https://marketplace.firefox.com/app/bitcasa-1?src=search
Unfortunately bug 858787 (mentioned in comment 5) is not present in these pushlog. 

Also - because of the age (in the distant past) of these builds, it seems like inbound builds were pushed less frequently back then resulting in larger gaps between 'last working' and 'first broken' builds meaning some pretty sizeable pushlogs.

Typically I try to dig through the pushlog and find a candidate that might have broken the issue but these pushlogs are over my head in both the number of commits and the technical details of them.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Looks like we're going to have investigate this the old fashioned way.

Andrew - Is there someone you could recommend from the DOM team that work on diagnosing the root cause of this bug?
Component: Gaia::System::Window Mgmt → DOM
Flags: needinfo?(overholt)
Product: Firefox OS → Core

Comment 11

4 years ago
This is caused by bug 990353, which is a rather obvious candidate from the inbound regression.  To verify you can set the javascript.options.discardSystemSource pref to false, and that "fixes" this.

Please get the author of the app to fix their code to not use function.toString (that is done at least in ./dependencies/angular.js line 2376 in the app package).  We are not going to modify our behavior here.
Blocks: 990353
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(overholt)
Resolution: --- → WONTFIX
Okay, sounds good. I'd like to reopen this bug to be tracked as a TE issue for the app developer to fix. Does that sound okay to you?
Component: DOM → Preinstalled B2G Apps
Flags: needinfo?(ehsan)
Product: Core → Tech Evangelism

Updated

4 years ago
blocking-b2g: 2.0? → ---

Comment 13

4 years ago
(In reply to Jason Smith [:jsmith] from comment #12)
> Okay, sounds good. I'd like to reopen this bug to be tracked as a TE issue
> for the app developer to fix. Does that sound okay to you?

Of course!  Thanks.
Flags: needinfo?(ehsan)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
You need to log in before you can comment on or make changes to this bug.