Last Comment Bug 104992 - Rendering problems with older ATI video cards
: Rendering problems with older ATI video cards
Status: RESOLVED INCOMPLETE
: meta
Product: Core Graveyard
Classification: Graveyard
Component: Tracking (show other bugs)
: Trunk
: All All
: -- normal with 8 votes (vote)
: ---
Assigned To: Mike Schuette
: chris hofmann
Mentors:
http://www.churchill.com/
: 94494 96803 131973 142139 146717 149020 149919 151081 156907 163907 173045 179100 183172 184836 204816 230191 transparent_gifs (view as bug list)
Depends on: 102401 77282 80292 90657 101357 101749 102363 108070 149599 184836 197751
Blocks: 150625 151081 transparent_gifs
  Show dependency treegraph
 
Reported: 2001-10-15 20:22 PDT by Mike Schuette
Modified: 2016-07-15 12:13 PDT (History)
32 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Shot of one such diseased computer (84.72 KB, image/png)
2002-02-22 15:23 PST, Shark Daddy (Jonathan L.)
no flags Details
Another such shot in Classic (81.63 KB, image/png)
2002-02-23 19:47 PST, Shark Daddy (Jonathan L.)
no flags Details
SOME GRAPHIC IMAGES DO NOT WORK until PRESSING F11; THEN OK. (108.41 KB, image/gif)
2002-10-28 08:45 PST, W. Baker
no flags Details
Graphic does not display properly (screenshot of the problem) (64.07 KB, image/jpeg)
2005-01-18 23:15 PST, crf
no flags Details

Description Mike Schuette 2001-10-15 20:22:11 PDT
There seem to be a lot of unconfirmed bugs being filed lately from users
complaining of corrupt rendering, ranging from a few minor blemishes to complete
chaos.  All of them are using ATI videocards.

I'm filing this to keep track of these bugs, and hoping someone will be able to
confirm/pinpoint or deny this problem.
Comment 1 Mike Schuette 2001-10-15 20:25:32 PDT
Adding meta, setting initial dependencies to 101634,101749,102363,102401.
Comment 2 Alex Vincent [:WeirdAl] 2001-10-20 20:04:34 PDT
What's going on?  I've seen this bug a few times in the UNCO list... but the
dependencies have been added twice and removed twice...
Comment 3 Mike Schuette 2001-10-20 22:35:21 PDT
First time the dependencies were removed (and re-added), I mid-air'ed with
myself, having the bugs open in another window.

This time, I have no clue ...  I blame Bin Laden.
Comment 4 Mike Schuette 2001-11-02 02:07:33 PST
This appears to be win98-specific, as the reporter in 102363 commented that the
problem went away after upgrading to windows 2000.

I do realize that this is probably a driver issue, and won't get "fixed", but
would like to see this qa'ed to the point of having either a definite known
issue or not.
Comment 5 Matthias Versen [:Matti] 2001-11-04 04:29:21 PST
This is a tracking bug -> tracking
And you filed this tracking -> assigned to you
(BTW: ATI should fix their drivers)
Comment 6 Shark Daddy (Jonathan L.) 2002-02-22 15:23:55 PST
Created attachment 70989 [details]
Shot of one such diseased computer

 Added here is a pic of my Mozilla {Build ID: 2002022103} on Win98 with a
kruddy ATI RAGE LT PRO AGP 2X card @ 1024 x 768. Note the top part with the
MozillaZine icons. FYI, ATI users have had to put up with this weird picture
display (which gets worse when you start scrolling) since before Netscape 6.0
times, probably since the inception of this project.

 I think the chrome problem (surely you can see the crapped-up Nav Bar, sidebar
and scrollbar, also the loading bar) is unrelated to this, and is happening to
me only so just look at the web content (but anyone who knows what's wrong with
chrome could always help me out with that too...:) and ignore the frontend.
Comment 7 Shark Daddy (Jonathan L.) 2002-02-23 19:47:02 PST
Created attachment 71142 [details]
Another such shot in Classic

 Have a look at the first attachment ("Shot of one"). See the weird stuff on
the MozillaZine .gif? Well it looks like the ONLY problem here with these old
ATI cards on win98 (in other words on most of the computers Compaq has made
recently) is rendering .gifs. Every time I see this problem (which is far too
often to be ignored), the problem appears to be with .gifs. Now I don't know
much about how .xul is implemented, but aren't buttons in themes in .gif
format? Because when you see attachment #2 [details] [diff] [review] ("Another shot"), the frontend
buttons aren't rendered right.

 By the way, the same rendering problems with .gifs and with the frontend come
up on another computer I have running Win98 and an even older ATI card (same
Mozilla build).
Comment 8 Andrew Hagen 2002-05-11 06:50:43 PDT
Proposed relnote: Using Windows 98 with some ATI graphics adapters will result
in corrupt inline image rendering on web pages.
Comment 9 Stuart Parmenter 2002-05-15 20:35:24 PDT
*** Bug 142139 has been marked as a duplicate of this bug. ***
Comment 10 Aaron Greenspan 2002-05-27 22:22:22 PDT
With an ATI 32MB RADEON SDR video card from late 2000 that came with my Gateway 
machine, I have experienced similar problems (with transparent GIFs, 
scrollbars, and scrolling in particular). However, I just noticed that 
Gateway's "latest drivers" are far from the actual latest drivers at ati.com, 
so I'm going to upgrade as soon as possible. You may want to advise users with 
similar problems to bypass their OEMs' support sites and go straight to ati.com 
in order to resolve their difficulties. These bad drivers also cause problems 
with other programs, including Photoshop, so I would hope that by now, ATI has 
heard about and fixed them.
Comment 11 Ian Westcott 2002-05-29 07:58:43 PDT
I have been tracking this problem for a while, I'm glad to hear that there are 
other people out there who see it.  
I opened but 121778 once upon a time (see information and attachments there) 
and it was later marked as a duplicate of but 94494, which is still open.  
Adding 94494 to dependency.  

I first saw the problem on an NEC computer running Win98 with an ATI RAGE PRO 
TURBO at 800x600x32 bit, which fits the hypothesis.  I can confirm that the 
problem is only with transparent .gif's (although transparent PNG's may be 
problematic as well, I'm not sure.)
Comment 12 Andrew Hagen 2002-05-29 14:33:25 PDT
Upgrading the driver is not necessarily feasible. On a system with an ATI Rage
Pro LT, I upgraded from the May 1999 driver to the "alternate" driver. That
solved the display problems covered by this bug. Then, a month later the system
became unstable and wouldn't boot into the Windows GUI. It was difficult to
restore the original driver. The machine is now using the old driver and is stable.
Comment 13 junk 2002-06-04 23:27:03 PDT
I had a problem as shown here: http://scootrs.com/images/moz_imageprob.jpg

Sometimes bottom is black, or has bit of other tabs, etc.

I just upgraded my ati rage 128 xpert driver here:
http://www.ati.com/support/products/pc/rage128/rage128drivers.html

and now is fine again. I did upgrade to directX 8.1 first, but that did nothing.

win98

Was driving me nuts, but there's the solution for me anyway.
Comment 14 Andrew Hagen 2002-06-06 14:24:05 PDT
This report now appears to be affecting Windows 2000, too. Changing summary to
reflect that.
Comment 15 Ian Neal 2002-06-09 07:55:22 PDT
I have an ATI rage Pro Turbo AGP using driver 5.0.2195.5013 (Oct 2001 which is
latest version) on Win2KSP2 and see problems too on Build ID 2002060408
Comment 16 Ian Neal 2002-06-09 08:19:37 PDT
bug 1049919 is related?
Comment 17 Ian Neal 2002-06-09 12:06:37 PDT
That should have been bug 149919
Comment 18 Andrew Hagen 2002-06-09 12:35:10 PDT
*** Bug 149919 has been marked as a duplicate of this bug. ***
Comment 19 Ian Neal 2002-06-11 15:46:14 PDT
a URL which shows this up alot is http://www.churchill.com/ which has a
scrolling text window. Very visible!
Comment 20 mgueury 2002-06-12 03:20:34 PDT
I have the same problem with a S3 Savage card. (Windows 2000)
Comment 21 Ian Neal 2002-06-12 13:27:15 PDT
bug 149020 is probably a dupe too
Comment 22 Matthias Versen [:Matti] 2002-06-12 13:49:23 PDT
*** Bug 149020 has been marked as a duplicate of this bug. ***
Comment 23 franCk 2002-06-15 00:36:07 PDT
I have observed a similar problem (resized image were corrupted - see bug 151081
and attachment there) and it was solved by using the 'alternate driver' provided
on the ATI website (as suggested by comment 13).

May I suggest that this bugs, and the similar ones, are not dupped when their
summary is different? Apparently the problem with the ATI driver can have
multiple effects, and also the cause is the same, it is not obvious to analyse
that when you're a normal user... thus using bugzilla you'll never check for
'ATI video card', and 'rendering problem' is not specific enough to be of any
help (Did you ever use the word 'rendering' in a search? At least the summary
should have the word image, no?!)
In the other hand please add the bug 151081 in the dependancy list...
OK if you feel I'm wrong with my idea of letting a bug open which is a duplicate
and not even a Mozilla bug, tell me :-)
Comment 24 franCk 2002-06-15 00:54:31 PDT
BTW, the information is available in the release note for 1.0 as:
 
"Using Windows 98 with some ATI graphics adapters will result in occasional
corruption of inline images as rendered on web pages. This is an ATI graphics
driver bug. (Bug 122445)"

You notice that there is a bug here: the referenced bug 122445 has nothing to do
with this issue, it should be this bug 104992... but the link is right, when you
click on it you're brought here!

OK, I'm sure this message is close to spam, but I don't know how to contact the
relnote guys otherwise... Sorry!
Comment 25 Michael Bruck 2002-06-18 10:20:16 PDT
I have a similar problem with an ATI RAGE 128 PRO, Win 98 SE, ATI driver
06.34-CD16-1C or 4.12.6292.

My Mozilla 0.9.7 2001122106 doesn't show this problem while 1.0 messes up our
homepage under http://www.digenius.de

The pages heavily uses PNG as table backgrounds.
Comment 26 Asa Dotzler [:asa] 2002-06-24 12:23:37 PDT
*** Bug 131973 has been marked as a duplicate of this bug. ***
Comment 27 Andrew Hagen 2002-06-25 08:17:00 PDT
Bug 149387 handles the release note issue.
Comment 28 Damir Perisa 2002-07-11 14:31:30 PDT
*** Bug 156907 has been marked as a duplicate of this bug. ***
Comment 29 Damir Perisa 2002-07-11 14:32:24 PDT
yes, i use ATI (mach64)
Comment 30 Damir Perisa 2002-07-11 14:37:20 PDT
have a look at my attachements in bug 156907
Comment 31 Damir Perisa 2002-07-11 15:07:49 PDT
 problem solved using 24bit colours with newest diver from ATI 
(using 32bit or 16bit colours remained the same) 
Comment 32 Andrew Hagen 2002-07-11 15:41:07 PDT
See comment 12 for a brief note about a stability problem with one of the new
ATI drivers. 
Comment 33 Steven Neil Groginsky 2002-07-11 15:47:54 PDT
I'm using win98se and an ATI 2x AGP 8 MB Rage XL (98 Xpert) card.  I have
observed complete distortions of images near the top of the page several times
which are mostly noise, but with some vertical darker lines I saw as layers -
reminded me of a broadcast tv where the vertical was out, except of course it
wasn't moving.

I think AGP boards are very tricky and some do some "dirty hardware tricks" to
maximize efficiency.  There are settings in the BIOS (CMOS) for several
different functions and you can set the video via all sorts of different
software functions.  Of course, you're supposed to get a uniformly good result :)
Comment 34 Bill Mason 2002-07-21 03:16:21 PDT
*** Bug 151081 has been marked as a duplicate of this bug. ***
Comment 35 Matthias Versen [:Matti] 2002-08-04 15:53:05 PDT
*** Bug 146717 has been marked as a duplicate of this bug. ***
Comment 36 Stephen Jungels 2002-08-10 22:21:53 PDT
Adding 149599 as dependency.  See my comments there.  I see these effects
(scrollbar artifacts) with my ATI RAGE MOBILITY-M PCI in spite of installing the
latest recommended driver from IBM Update Connector.
Comment 37 Steve Hill 2002-08-22 16:50:54 PDT
I'm not sure if this is what this bug (#104992) is related to, but on an
E-Machine 667Mhz, with Intel 82810 Graphics Controller connected over the PCI
bus (i.e. not ATI) and running Windows ME, when I use the scroll button on a
page, some typed lines at "squished" by what appears to have been a dropped
raster, while others are "tall" with an added raster line.

It is only a minor annoyance, easily corrected by a page-up/page-down, but
figured that I ought to report it for a better Mozilla.

Steve
Comment 38 Daniel Herring 2002-09-23 09:00:50 PDT
Bug #96803 also discusses this bug.
Over there, dropping the bit depth from 32 to 24-bit seems to fix many people's
problems.

Is there any way this information could make its way into the release notes?
Comment 39 Daniel Wang 2002-10-26 18:44:20 PDT
ATI prob in release note is bug 169264
Comment 40 Daniel Wang 2002-10-26 18:44:50 PDT
*** Bug 163907 has been marked as a duplicate of this bug. ***
Comment 41 W. Baker 2002-10-28 08:45:35 PST
Created attachment 104374 [details]
SOME GRAPHIC IMAGES DO NOT WORK until PRESSING F11; THEN OK.

As above:  
SOME GRAPHIC IMAGES DO NOT WORK until PRESSING F11; THEN OK
Comment 42 Torben 2002-11-08 13:59:52 PST
*** Bug 179100 has been marked as a duplicate of this bug. ***
Comment 43 Andrew Hagen 2002-11-20 07:31:45 PST
On comment 31 and 32, I'm using the latest stable ATI driver for Rage Pro LT,
with 24 bit color. I haven't seen graphics corruption since I switched from 32
bit to 24 bit. I can confirm that using 24 bit color is a workaround.
Comment 44 Torben 2002-12-03 05:49:30 PST
*** Bug 183172 has been marked as a duplicate of this bug. ***
Comment 45 David Chaiken 2003-03-04 21:50:20 PST
I solved this problem by upgrading from ATI RAGE LT PRO
driver version 4.10.2456 to 4.11.2560.

The system in question is a Compaq Presario 5610 with a
FP500 (flat panel) monitor.

More information about the drivers is at:  
http://www.ati.com/support/products/pc/rageltpro/win98/rageltprowin98drivers.html
Comment 46 Andrew Hagen 2003-03-05 09:11:59 PST
Re: previous comment. That's the driver I was talking about in comment 12 when I
warned of the driver causing system instability. Incidentally, this system is a
Compaq Prosignia 150. When the instability problem reared its head after several
largely uneventful weeks, my system would not boot. I had to install a different
driver. After great time and effort, I able to install the older driver again.

I strongly recommend using the older, stable driver for Rage LT Pro. This bug
(rendering problems) can be avoided by using the older driver and setting the
color depth to 24 bit, and not 32 bit.
Comment 47 George 2003-03-05 09:58:47 PST
I "solved" this bug by selecting TrueColor (24 bit) 1280 x 1024 with Rage IIC
AGP (Mach64GT chip) Driver 5.24-CD3 on a Win98 machine

George
Comment 48 Andrew Hagen 2003-03-10 14:26:14 PST
*** Bug 94494 has been marked as a duplicate of this bug. ***
Comment 49 Jens Tinz 2003-03-28 13:23:46 PST
More ATI trouble.

I'm using an ATI XPERT 98 RXL AGP 2x card with driver v5.0.2195.5013.
OS is Win2k SP3.

Till now I didn't have any problems. But the current nightly 
(BuildID 2003032808) does not render the right and bottom edges
of frames at all. 
When scrolling, the whole frame becomes a mess.
The bug occurs in 6, 16 and 32 bpp modes.

I uploaded screenshots at:
www.gamemakers.de/mozilla/started.png
www.gamemakers.de/mozilla/scrolled.png
Comment 50 Pascal Chevrel:pascalc 2003-05-07 21:05:23 PDT
*** Bug 204816 has been marked as a duplicate of this bug. ***
Comment 51 Christopher Hoess (gone) 2003-06-08 14:10:46 PDT
*** Bug 96803 has been marked as a duplicate of this bug. ***
Comment 52 Frank J Rossi Jr 2003-06-08 18:06:23 PDT
By switching my video setings to 24bit color, from 32bit color, the problem
scrolling (rendering)is now gone.
Comment 53 Martin von Gagern 2004-01-07 04:25:14 PST
*** Bug 230191 has been marked as a duplicate of this bug. ***
Comment 54 Asa Dotzler [:asa] 2004-02-03 10:21:25 PST
*** Bug 173045 has been marked as a duplicate of this bug. ***
Comment 55 Ajay Gandhi 2004-06-04 08:27:08 PDT
Please goto http://www.washingtonpost.com and it goes into a infinite loop and 
keeps on re-loading the page
Comment 56 Alexander 'Chewie' Hirzel 2004-06-06 10:14:09 PDT
That's bug 235871.
Comment 57 Eike Sauer 2004-06-16 06:22:50 PDT
*** Bug 184836 has been marked as a duplicate of this bug. ***
Comment 58 Caroline Tang 2004-10-05 08:15:35 PDT
I'm also experiencing this bug on my Mac -- a late 2001 dual USB white iBook, OS X (10.3.5) with an 
ATI Rage video card.  Here's a screenshot of a broken-up gif:
http://sacrelicious.org/images/firefoxproblem.jpg

Here's the info for my video card from the System Profiler:
  Type:	display
  Bus:	AGP
  Display Type:	LCD
  Slot:	ATI
  VRAM (Total):	8 MB
  Vendor:	ATI (0x1002)
  Device ID:	0x4c46
  Revision ID:	0x0002
  ROM Revision:	113-XXXXX-130
Comment 59 Mike Schuette 2004-10-28 19:40:58 PDT
Marking hardware: all, OS: all.
Comment 60 crf 2005-01-18 23:15:12 PST
Created attachment 171719 [details]
Graphic does not display properly (screenshot of the problem)

This is a pic taken from the website -->
http://www.chessbase.com/newsdetail.asp?newsid=2144
The graphic does not display properly when it initially loads -- it will remain
corrupted if you scroll the web page, although the appearance of the corrupted
image does change while scrolling.
Comment 61 crf 2005-01-19 22:20:17 PST
I change the colour display properties (as suggested in earlier posts in this
bug report) to "true colour (24 bit)" and the problem immediately went away.
Comment 62 TJ Brown 2005-03-04 19:11:05 PST
Have a 2001 500MHz iMacDV, OSX 10.2.8.
Video listed as ATY,Rage128Pk, card=ATY,Rage128Pro, ROM#=113-XXXXX-109 rev 0, 8MB.
Using Mozilla 1.7.5 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.5) Gecko/20041217)
When Graphics Display Color is set less than "Millions"
many images are "streaked"

Doesn't happen in Firefox 1.0.1 (Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1)
Comment 63 Jasper Lieber 2005-03-28 10:33:34 PST
*** Bug 284986 has been marked as a duplicate of this bug. ***
Comment 64 Jasper Lieber 2005-03-29 17:15:46 PST
(In reply to comment #63)
> *** Bug 284986 has been marked as a duplicate of this bug. ***

And now that I've updated my ATI graphics drivers, I'm not seeing rendering
problems, wahoooo!  (This is after posting alot to Bug 284986 and Bug 201198 -
oh well!  I'm so glad my sys is better, now.)
Comment 65 BMO Automation 2016-07-01 13:04:04 PDT
Marking all tracking bugs which haven't been updated since 2014 as INCOMPLETE.
If this bug is still relevant, please reopen it and move it into a bugzilla component related to the work
being tracked. The Core: Tracking component will no longer be used.

Note You need to log in before you can comment on or make changes to this bug.